Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-34771

Problem in Jenkins RTC Plugin

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Won't Fix
    • Component/s: teamconcert-plugin
    • Labels:
    • Environment:
      Jenkins version: 2.1
      Team Concert Plugin: 1.2.0.0
      RTC version: 5.0.2 iFix 14
    • Similar Issues:

      Description

      I'm facing the following problem in Jenkins RTC Plugin, using the option "Build Stream" for Build Configuration.

      Logs:

      RTC : checkout...
      FATAL: RTC : checkout failure: null
      com.ibm.team.repository.common.TeamRepositoryException
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
      at java.lang.reflect.Constructor.newInstance(Constructor.java:526)
      at com.ibm.team.repository.transport.client.RemoteTeamService.getAppropriateException(RemoteTeamService.java:704)
      at com.ibm.team.repository.transport.client.RemoteTeamService.executeMethod(RemoteTeamService.java:506)
      at com.ibm.team.repository.transport.client.RemoteTeamService.invoke(RemoteTeamService.java:194)
      at com.ibm.team.repository.transport.client.ServiceInvocationHandler.invoke(ServiceInvocationHandler.java:43)
      at com.sun.proxy.$Proxy28.getComponentEntries(Unknown Source)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:606)
      at com.ibm.team.repository.client.internal.ServiceInterfaceProxy.invokeServiceCall(ServiceInterfaceProxy.java:254)
      at com.ibm.team.repository.client.internal.ServiceInterfaceProxy.invoke(ServiceInterfaceProxy.java:110)
      at com.sun.proxy.$Proxy28.getComponentEntries(Unknown Source)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:606)
      at com.ibm.team.scm.client.internal.ScmServiceInterfaceProxy$2.run(ScmServiceInterfaceProxy.java:168)
      at com.ibm.team.repository.client.internal.TeamRepository$3.run(TeamRepository.java:1320)
      at com.ibm.team.repository.common.transport.CancelableCaller.call(CancelableCaller.java:79)
      at com.ibm.team.repository.client.internal.TeamRepository.callCancelableService(TeamRepository.java:1315)
      at com.ibm.team.scm.client.internal.ScmClientLibraryContext.callCancelableService(ScmClientLibraryContext.java:71)
      at com.ibm.team.scm.client.internal.ScmServiceInterfaceProxy.invokeCancelableService(ScmServiceInterfaceProxy.java:164)
      at com.ibm.team.scm.client.internal.ScmServiceInterfaceProxy.invoke(ScmServiceInterfaceProxy.java:92)
      at com.sun.proxy.$Proxy28.getComponentEntries(Unknown Source)
      at com.ibm.team.scm.client.internal.WorkspaceManager.getComponentEntries(WorkspaceManager.java:2940)
      at com.ibm.team.scm.client.internal.RepositoryItemProvider.fetchComponentEntriesFor(RepositoryItemProvider.java:140)
      at com.ibm.team.build.internal.hjplugin.rtc.RTCWorkspaceUtils.getDigest(RTCWorkspaceUtils.java:184)
      at com.ibm.team.build.internal.hjplugin.rtc.RepositoryConnection.acceptForBuildStream(RepositoryConnection.java:1425)
      at com.ibm.team.build.internal.hjplugin.rtc.RepositoryConnection.accept(RepositoryConnection.java:424)
      at com.ibm.team.build.internal.hjplugin.rtc.RTCFacade.accept(RTCFacade.java:443)
      at sun.reflect.GeneratedMethodAccessor196.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:606)
      at com.ibm.team.build.internal.hjplugin.RTCFacadeFactory$RTCFacadeWrapper.invoke(RTCFacadeFactory.java:125)
      at com.ibm.team.build.internal.hjplugin.RTCAcceptTask.invoke(RTCAcceptTask.java:186)
      at com.ibm.team.build.internal.hjplugin.RTCAcceptTask.invoke(RTCAcceptTask.java:34)
      at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2719)
      at hudson.remoting.UserRequest.perform(UserRequest.java:120)
      at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      at hudson.remoting.Request$2.run(Request.java:332)
      at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      at java.util.concurrent.FutureTask.run(FutureTask.java:262)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      at java.lang.Thread.run(Thread.java:745)
      Caused by: com.ibm.team.repository.common.internal.marshal.MarshallingException
      at com.ibm.team.repository.common.internal.marshal.impl.FastWebDemarshaller.getFeature(FastWebDemarshaller.java:1867)
      at com.ibm.team.repository.common.internal.marshal.impl.FastWebDemarshaller.demarshalObject(FastWebDemarshaller.java:2046)
      at com.ibm.team.repository.common.internal.marshal.impl.FastWebDemarshaller.demarshal(FastWebDemarshaller.java:2197)
      at com.ibm.team.repository.common.internal.marshal.impl.EObjectMarshaller.internalFastDemarshal(EObjectMarshaller.java:627)
      at com.ibm.team.repository.common.internal.marshal.impl.EObjectMarshaller.demarshalInputStreamToObject(EObjectMarshaller.java:591)
      at com.ibm.team.repository.transport.client.RemoteTeamService.demarshallEnvelope(RemoteTeamService.java:602)
      at com.ibm.team.repository.transport.client.RemoteTeamService.invokePost(RemoteTeamService.java:541)
      at com.ibm.team.repository.transport.client.RemoteTeamService.executeMethod(RemoteTeamService.java:481)
      ... 43 more
      FATAL: RTC : checkout failure: RTC : checkout failure: null
      hudson.AbortException: RTC : checkout failure: null
      at com.ibm.team.build.internal.hjplugin.RTCAcceptTask.invoke(RTCAcceptTask.java:224)
      at com.ibm.team.build.internal.hjplugin.RTCAcceptTask.invoke(RTCAcceptTask.java:34)
      at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2719)
      at hudson.remoting.UserRequest.perform(UserRequest.java:120)
      at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      at hudson.remoting.Request$2.run(Request.java:332)
      at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      at java.util.concurrent.FutureTask.run(FutureTask.java:262)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      at java.lang.Thread.run(Thread.java:745)
      at ......remote call to linux.bsa(Native Method)
      at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1416)
      at hudson.remoting.UserResponse.retrieve(UserRequest.java:220)
      at hudson.remoting.Channel.call(Channel.java:781)
      at hudson.FilePath.act(FilePath.java:979)
      at hudson.FilePath.act(FilePath.java:968)
      at com.ibm.team.build.internal.hjplugin.RTCScm.checkout(RTCScm.java:1710)
      at hudson.scm.SCM.checkout(SCM.java:485)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:1269)
      at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:607)
      at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:529)
      at hudson.model.Run.execute(Run.java:1738)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:98)
      at hudson.model.Executor.run(Executor.java:410)
      ERROR: RTC : checkout failure: RTC : checkout failure: null

        Attachments

          Activity

          lvaikunt Lakshmi Narasimhan Vaikuntam added a comment -

          1.2.0.0 works with BuildToolkit version from 4.0.7. Using a 4.0.7 or later toolkit should solve the problem


            People

            Assignee:
            lvaikunt Lakshmi Narasimhan Vaikuntam
            Reporter:
            jhcruvinel José Humberto Cruvinel
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: