Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-34993

Publish over FTP plugin hangs up

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Labels:
      None
    • Environment:
      Linux, java version "1.7.0_55"
    • Similar Issues:

      Description

      FTPClient hangs occassionally.

      Plugin properties:
      Implementation-Title: ftppublisher
      Implementation-Version: 1.2
      Short-Name: ftppublisher
      Long-Name: FTP publisher plugin
      Url: http://wiki.hudson-ci.org/display/HUDSON/FTP-Publisher+Plugin
      Compatible-Since-Version: 1.0
      Plugin-Version: 1.2

      Stacktrace of a susspended thread:
      Executor #0 for JenkinsSlave14 : executing Ramos.Dev.jRamos.Unit #9892
      java.net.PlainSocketImpl.socketAccept(Native Method)
      java.net.AbstractPlainSocketImpl.accept(AbstractPlainSocketImpl.java:398)
      java.net.ServerSocket.implAccept(ServerSocket.java:530)
      java.net.ServerSocket.accept(ServerSocket.java:498)
      org.apache.commons.net.ftp.FTPClient.openDataConnection(FTPClient.java:502)
      org.apache.commons.net.ftp.FTPClient.__storeFile(FTPClient.java:388)
      org.apache.commons.net.ftp.FTPClient.storeFile(FTPClient.java:1388)
      com.zanox.hudson.plugins.FTPSite.upload(FTPSite.java:358)
      com.zanox.hudson.plugins.EntryCopier.copyFile(EntryCopier.java:87)
      com.zanox.hudson.plugins.EntryCopier.copy(EntryCopier.java:77)
      com.zanox.hudson.plugins.FTPPublisher.perform(FTPPublisher.java:179)
      hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:45)
      hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:779)
      hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:726)
      hudson.model.Build$BuildExecution.post2(Build.java:185)
      hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:671)
      hudson.model.Run.execute(Run.java:1766)
      hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      hudson.model.ResourceController.execute(ResourceController.java:98)
      hudson.model.Executor.run(Executor.java:381)

      The plugin uses jenkins/plugins/ftppublisher/WEB-INF/lib/commons-net-1.4.1.jar.
      Seems a similar problem described in https://issues.apache.org/jira/browse/NET-152.

      Could you update commons-net lib?

        Attachments

          Activity

          slide_o_mix Alex Earl added a comment -

          The version of commons-net has been updated since this issue, can you see if this is still an issue for you?


            People

            Assignee:
            slide_o_mix Alex Earl
            Reporter:
            stepanmelnik Stepan Melnik
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: