Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-36096

S3 Jenkins plugin missing transitive dependencies

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: s3-plugin
    • Labels:
      None
    • Similar Issues:

      Description

      For version 0.10.5, we upgraded to resolve JENKINS-34216. We're missing transitive dependencies:

      12:37:24 PDT ERROR: Build step failed with exception
      12:37:24 PDT com.amazonaws.AmazonClientException: Unable to complete transfer: org/apache/http/conn/ManagedHttpClientConnection
      12:37:24 PDT at com.amazonaws.services.s3.transfer.internal.AbstractTransfer.unwrapExecutionException(AbstractTransfer.java:277)
      12:37:24 PDT at com.amazonaws.services.s3.transfer.internal.AbstractTransfer.rethrowExecutionException(AbstractTransfer.java:261)
      12:37:24 PDT at com.amazonaws.services.s3.transfer.internal.AbstractTransfer.waitForCompletion(AbstractTransfer.java:103)
      12:37:24 PDT at hudson.plugins.s3.Uploads.finishUploading(Uploads.java:40)
      12:37:24 PDT at hudson.plugins.s3.callable.S3WaitUploadCallable.invoke(S3WaitUploadCallable.java:19)
      12:37:24 PDT at hudson.plugins.s3.callable.S3WaitUploadCallable.invoke(S3WaitUploadCallable.java:10)
      12:37:24 PDT at hudson.plugins.s3.S3Profile.invoke(S3Profile.java:203)
      12:37:24 PDT at hudson.plugins.s3.S3Profile.waitUploads(S3Profile.java:195)
      12:37:24 PDT at hudson.plugins.s3.S3Profile.upload(S3Profile.java:174)
      12:37:24 PDT at hudson.plugins.s3.S3BucketPublisher.perform(S3BucketPublisher.java:192)
      12:37:24 PDT at hudson.tasks.BuildStepCompatibilityLayer.perform(BuildStepCompatibilityLayer.java:78)
      12:37:24 PDT at hudson.tasks.BuildStepMonitor$2.perform(BuildStepMonitor.java:32)
      12:37:24 PDT at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:782)
      12:37:24 PDT at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:723)
      12:37:24 PDT at hudson.model.Build$BuildExecution.post2(Build.java:185)
      12:37:24 PDT at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:668)
      12:37:24 PDT at hudson.model.Run.execute(Run.java:1763)
      12:37:24 PDT at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      12:37:24 PDT at hudson.model.ResourceController.execute(ResourceController.java:98)
      12:37:24 PDT at hudson.model.Executor.run(Executor.java:410)
      12:37:24 PDT Caused by: java.lang.NoClassDefFoundError: org/apache/http/conn/ManagedHttpClientConnection
      12:37:24 PDT at com.amazonaws.http.protocol.SdkHttpRequestExecutor.doSendRequest(SdkHttpRequestExecutor.java:50)
      12:37:24 PDT at org.apache.http.protocol.HttpRequestExecutor.execute(HttpRequestExecutor.java:125)
      12:37:24 PDT at org.apache.http.impl.client.DefaultRequestDirector.tryExecute(DefaultRequestDirector.java:715)
      12:37:24 PDT at org.apache.http.impl.client.DefaultRequestDirector.execute(DefaultRequestDirector.java:520)
      12:37:24 PDT at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:906)
      12:37:24 PDT at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:805)
      12:37:24 PDT at com.amazonaws.http.AmazonHttpClient.executeOneRequest(AmazonHttpClient.java:837)
      12:37:24 PDT at com.amazonaws.http.AmazonHttpClient.executeHelper(AmazonHttpClient.java:607)
      12:37:24 PDT at com.amazonaws.http.AmazonHttpClient.doExecute(AmazonHttpClient.java:376)
      12:37:24 PDT at com.amazonaws.http.AmazonHttpClient.executeWithTimer(AmazonHttpClient.java:338)
      12:37:24 PDT at com.amazonaws.http.AmazonHttpClient.execute(AmazonHttpClient.java:287)
      12:37:24 PDT at com.amazonaws.services.s3.AmazonS3Client.invoke(AmazonS3Client.java:3826)
      12:37:24 PDT at com.amazonaws.services.s3.AmazonS3Client.initiateMultipartUpload(AmazonS3Client.java:2708)
      12:37:24 PDT at com.amazonaws.services.s3.transfer.internal.UploadCallable.initiateMultipartUpload(UploadCallable.java:350)
      12:37:24 PDT at com.amazonaws.services.s3.transfer.internal.UploadCallable.uploadInParts(UploadCallable.java:178)
      12:37:24 PDT at com.amazonaws.services.s3.transfer.internal.UploadCallable.call(UploadCallable.java:121)
      12:37:24 PDT at com.amazonaws.services.s3.transfer.internal.UploadMonitor.call(UploadMonitor.java:139)
      12:37:24 PDT at com.amazonaws.services.s3.transfer.internal.UploadMonitor.call(UploadMonitor.java:47)
      12:37:24 PDT at java.util.concurrent.FutureTask.run(FutureTask.java:266)
      12:37:24 PDT at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
      12:37:24 PDT at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
      12:37:24 PDT at java.lang.Thread.run(Thread.java:745)
      12:37:24 PDT Caused by: java.lang.ClassNotFoundException: org.apache.http.conn.ManagedHttpClientConnection
      12:37:24 PDT at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1376)
      12:37:24 PDT at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1326)
      12:37:24 PDT at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1079)
      12:37:24 PDT at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
      12:37:24 PDT ... 22 more

        Attachments

          Activity

          kcpublic Kevin Chen added a comment -

          I opened up https://updates.jenkins-ci.org/download/plugins/s3/

          The 0.10.5 installer has a completely different structure where you're not relying on Maven to download transitive dependencies compared to the older versions. 0.10.5 has all the aws jars but not the httpcore/client jars.

          kcpublic Kevin Chen added a comment - - edited

          Manually copying http client/core jars 4.4.1 didn't help.

          Now running into Amazon S3 runtime errors:

          Caused by: java.lang.NoSuchFieldError: INSTANCE
          15:58:20 PDT at com.amazonaws.http.conn.SdkConnectionKeepAliveStrategy.getKeepAliveDuration(SdkConnectionKeepAliveStrategy.java:48)
          15:58:20 PDT at org.apache.http.impl.client.DefaultRequestDirector.execute(DefaultRequestDirector.java:535)
          15:58:20 PDT at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:906)
          15:58:20 PDT at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:805)
          15:58:20 PDT at com.amazonaws.http.AmazonHttpClient.executeOneRequest(AmazonHttpClient.java:837)
          15:58:20 PDT at com.amazonaws.http.AmazonHttpClient.executeHelper(AmazonHttpClient.java:607)
          15:58:20 PDT at com.amazonaws.http.AmazonHttpClient.doExecute(AmazonHttpClient.java:376)
          15:58:20 PDT at com.amazonaws.http.AmazonHttpClient.executeWithTimer(AmazonHttpClient.java:338)
          15:58:20 PDT at com.amazonaws.http.AmazonHttpClient.execute(AmazonHttpClient.java:287)
          15:58:20 PDT at com.amazonaws.services.s3.AmazonS3Client.invoke(AmazonS3Client.java:3826)
          15:58:20 PDT at com.amazonaws.services.s3.AmazonS3Client.initiateMultipartUpload(AmazonS3Client.java:2708)
          15:58:20 PDT at com.amazonaws.services.s3.transfer.internal.UploadCallable.initiateMultipartUpload(UploadCallable.java:350)
          15:58:20 PDT at com.amazonaws.services.s3.transfer.internal.UploadCallable.uploadInParts(UploadCallable.java:178)
          15:58:20 PDT at com.amazonaws.services.s3.transfer.internal.UploadCallable.call(UploadCallable.java:121)
          15:58:20 PDT at com.amazonaws.services.s3.transfer.internal.UploadMonitor.call(UploadMonitor.java:139)
          15:58:20 PDT at com.amazonaws.services.s3.transfer.internal.UploadMonitor.call(UploadMonitor.java:47)
          15:58:20 PDT at java.util.concurrent.FutureTask.run(FutureTask.java:266)
          15:58:20 PDT at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
          15:58:20 PDT at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
          15:58:20 PDT at java.lang.Thread.run(Thread.java:745)
          15:58:20 PDT Build step 'Publish artifacts to S3 Bucket' marked build as failure

          kcpublic Kevin Chen added a comment -

          We need help. We're blocked.

          kcpublic Kevin Chen added a comment -

          We had to downgrade to 0.10.3. That worked.

          We're on Jenkins 2.1. If 0.10.5 is not compatible with Jenkins 2.1, you shouldn't allow the install

          kcpublic Kevin Chen added a comment -

          And we still need a fix for JENKINS-34216

          jimilian Alexander A added a comment -

          Solved in 0.10.5.1


            People

            Assignee:
            jimilian Alexander A
            Reporter:
            kcpublic Kevin Chen
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: