Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-36138

No msbuild section in configuration or global tools after install

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Blocker
    • Resolution: Not A Defect
    • msbuild-plugin
    • None
    • Jenkins 2.10 and msbuild plugin 1.25

    Description

      I have installed latest version but i cant set the path for msbuild.exe in configuration

      Attachments

        1. 1.JPG
          109 kB
          Lionel Cabasson
        2. 2.JPG
          59 kB
          Lionel Cabasson

        Issue Links

          Activity

            Hello,

            Could you please retry with msbuild-plugin 1.26 ?

            Thanks

            marshall777 Lionel Cabasson added a comment - Hello, Could you please retry with msbuild-plugin 1.26 ? Thanks
            comsiro Sahyun Kim added a comment -

            Same error...

            comsiro Sahyun Kim added a comment - Same error...

            Also do not see this on a Mac Mini fresh jenkins install on version 1.26

            agciber Antonio Guglielmo added a comment - Also do not see this on a Mac Mini fresh jenkins install on version 1.26

            I recommend combining this report with JENKINS-34577 since the details seems to indicate the same behavior

            agciber Antonio Guglielmo added a comment - I recommend combining this report with JENKINS-34577 since the details seems to indicate the same behavior

            Rolled Jenkins Back to 1.651.3 and can now see the admin configuration at a global level. Seems to be a version mismatch in some config / and or the missing global.jelly that I can see some other plugins that are working successfully. Its a issue with the jenkins version, not the plugin specifically but should be enhanced to support the new versions of jenkins.

            agciber Antonio Guglielmo added a comment - Rolled Jenkins Back to 1.651.3 and can now see the admin configuration at a global level. Seems to be a version mismatch in some config / and or the missing global.jelly that I can see some other plugins that are working successfully. Its a issue with the jenkins version, not the plugin specifically but should be enhanced to support the new versions of jenkins.

            agciber Thanks for your feedback, I may try to investigate this matter when I can find some time.

            marshall777 Lionel Cabasson added a comment - agciber Thanks for your feedback, I may try to investigate this matter when I can find some time.

            Hello,

            I tested it on Jenkins 2.7.1 and I can see the msbuild configuration section. However the configuration of tools is not anymore in the "Configure System" but in the "Global Tool Configuration" (see linked screenshots). I guess you're simply looking at the wrong place (as I did for quite some time).

            marshall777 Lionel Cabasson added a comment - Hello, I tested it on Jenkins 2.7.1 and I can see the msbuild configuration section. However the configuration of tools is not anymore in the "Configure System" but in the "Global Tool Configuration" (see linked screenshots). I guess you're simply looking at the wrong place (as I did for quite some time).

            People

              marshall777 Lionel Cabasson
              govendhan Govendhan Chandrasekar
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: