Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-362

1.86 No longer starts in Tomcat

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: Sun, OS: Solaris
    • Similar Issues:

      Description

      In my attempt to update my Hudson war from 1.74 to 1.86 I was unable to successfully startup the
      newly deployed 1.86 war in Tomcat 5.5.17 under Java 1.5.0_06-b05. Tomcat's catalina.out log
      reported the following:

      Mar 13, 2007 5:15:07 PM hudson.TcpSlaveAgentListener <init>
      INFO: JNLP slave agent listener started on TCP port 42181
      Mar 13, 2007 5:15:07 PM org.apache.catalina.core.StandardContext start
      SEVERE: Error listenerStart
      Mar 13, 2007 5:15:07 PM org.apache.catalina.core.StandardContext start
      SEVERE: Context [/hudson] startup failed due to previous errors
      Mar 13, 2007 5:15:57 PM org.apache.catalina.core.StandardContext stop
      INFO: Container org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/hudson] has not been
      started

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          Check the $TOMCAT_HOME/logs/localhost_log.*.txt, which should contain
          the details for the error. We need to see that to find out what's wrong.

          kohsuke Kohsuke Kawaguchi added a comment -

          No comment from the submitter, so I'm closing this issue.

          If anyone experiences a similar issue or have more details, please reopen this
          issue.

          levibrown levibrown added a comment -

          Sorry, I did not see the prompt for more info. Here's the exception from the logs:

          Mar 13, 2007 5:12:12 PM org.apache.catalina.core.StandardContext listenerStart
          SEVERE: Exception sending context initialized event to listener instance of class hudson.WebAppMain
          java.lang.Error: hudson.util.IOException2: Unable to read /app/hudson-home/config.xml
          at hudson.WebAppMain.contextInitialized(WebAppMain.java:86)
          at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3729)
          at org.apache.catalina.core.StandardContext.start(StandardContext.java:4187)
          at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:759)
          at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:739)
          at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:524)
          at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:809)
          at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:497)
          at org.apache.catalina.startup.HostConfig.check(HostConfig.java:1204)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
          at java.lang.reflect.Method.invoke(Method.java:585)
          at org.apache.commons.modeler.BaseModelMBean.invoke(BaseModelMBean.java:503)
          at com.sun.jmx.mbeanserver.DynamicMetaDataImpl.invoke(DynamicMetaDataImpl.java:213)
          at com.sun.jmx.mbeanserver.MetaDataImpl.invoke(MetaDataImpl.java:220)
          at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke
          (DefaultMBeanServerInterceptor.java:815)
          at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(JmxMBeanServer.java:784)
          at org.apache.catalina.manager.ManagerServlet.check(ManagerServlet.java:1377)
          at org.apache.catalina.manager.HTMLManagerServlet.doPost(HTMLManagerServlet.java:213)
          at javax.servlet.http.HttpServlet.service(HttpServlet.java:709)
          at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
          at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
          at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
          at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
          at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
          at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:524)
          at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
          at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
          at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
          at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
          at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
          at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection
          (Http11BaseProtocol.java:664)
          at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
          at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt
          (LeaderFollowerWorkerThread.java:80)
          at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
          at java.lang.Thread.run(Thread.java:595)
          Caused by: hudson.util.IOException2: Unable to read /app/hudson-home/config.xml
          at hudson.XmlFile.unmarshal(XmlFile.java:118)
          at hudson.model.Hudson.load(Hudson.java:813)
          at hudson.model.Hudson.<init>(Hudson.java:191)
          at hudson.WebAppMain.contextInitialized(WebAppMain.java:84)
          ... 36 more
          Caused by: com.thoughtworks.xstream.converters.ConversionException: Cannot deserialize object with
          new readObject()/writeObject() methods
          ---- Debugging information ----
          required-type : edu.emory.mathcs.backport.java.util.concurrent.ConcurrentHashMap
          class : hudson.model.Hudson
          line number : 10
          path : /hudson/fingerprintMap/core
          -------------------------------
          at com.thoughtworks.xstream.converters.reflection.SerializableConverter.unmarshal
          (SerializableConverter.java:252)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:38)
          at com.thoughtworks.xstream.core.ReferenceByXPathUnmarshaller.convertAnother
          (ReferenceByXPathUnmarshaller.java:39)
          at com.thoughtworks.xstream.converters.reflection.ReflectionConverter.unmarshal
          (ReflectionConverter.java:103)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:38)
          at com.thoughtworks.xstream.core.ReferenceByXPathUnmarshaller.convertAnother
          (ReferenceByXPathUnmarshaller.java:39)
          at com.thoughtworks.xstream.converters.reflection.ReflectionConverter.unmarshal
          (ReflectionConverter.java:103)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:38)
          at com.thoughtworks.xstream.core.ReferenceByXPathUnmarshaller.convertAnother
          (ReferenceByXPathUnmarshaller.java:39)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.start(TreeUnmarshaller.java:99)
          at com.thoughtworks.xstream.core.ReferenceByXPathMarshallingStrategy.unmarshal
          (ReferenceByXPathMarshallingStrategy.java:12)
          at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:552)
          at hudson.util.XStream2.unmarshal(XStream2.java:36)
          at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:540)
          at hudson.XmlFile.unmarshal(XmlFile.java:114)
          ... 39 more

          kohsuke Kohsuke Kawaguchi added a comment -

          Fixed in 1.91.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            levibrown levibrown
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: