Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-36378

Jenkins Server caught Blue Dump Screen and crashed

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
    • Similar Issues:

      Description

      Jenkins Server get blue screen to death crash once every day.Below is the crash dump summary:

      ******************************************************************************

      • *
      • Bugcheck Analysis *
      • *

      Use !analyze -v to get detailed debugging information.

      BugCheck F4,

      {3, fffffa8018b69b10, fffffa8018b69df0, fffff80001b82e40}

      ----- ETW minidump data unavailable-----

      Probably caused by : csrss.exe

      Followup: MachineOwner
      ---------

      kd> !analyze -v

      *******************************************************************************

      • *
      • Bugcheck Analysis *
      • *

      CRITICAL_OBJECT_TERMINATION (f4)

      A process or thread crucial to system operation has unexpectedly exited or been

      terminated.

      Several processes and threads are necessary for the operation of the

      system; when they are terminated (for any reason), the system can no

      longer function.

      Arguments:

      Arg1: 0000000000000003, Process

      Arg2: fffffa8018b69b10, Terminating object

      Arg3: fffffa8018b69df0, Process image file name

      Arg4: fffff80001b82e40, Explanatory message (ascii)

      Debugging Details:
      ------------------

      ----- ETW minidump data unavailable-----

      PROCESS_OBJECT: fffffa8018b69b10

      IMAGE_NAME: csrss.exe

      DEBUG_FLR_IMAGE_TIMESTAMP: 0

      MODULE_NAME: csrss

      FAULTING_MODULE: 0000000000000000

      PROCESS_NAME: jenkins-slave.

      BUGCHECK_STR: 0xF4_jenkins-slave.

      CUSTOMER_CRASH_COUNT: 1

      DEFAULT_BUCKET_ID: WIN7_DRIVER_FAULT_SERVER

      CURRENT_IRQL: 0

      ANALYSIS_VERSION: 6.3.9600.17336 (debuggers(dbg).150226-1500) amd64fre

      LAST_CONTROL_TRANSFER: from fffff80001c101c2 to fffff8000187b400

      STACK_TEXT:
      fffff880`08bd0b18 fffff800`01c101c2 : 00000000`000000f4 00000000`00000003 fffffa80`18b69b10 fffffa80`18b69df0 : nt!KeBugCheckEx
      fffff880`08bd0b20 fffff800`01bcc83b : 00000000`00000001 fffffa80`13d3fb50 fffffa80`18b69b10 fffffa80`0c3d3501 : nt!PspCatchCriticalBreak+0x92
      fffff880`08bd0b60 fffff800`01b33484 : 00000000`00000001 00000000`00000320 fffffa80`18b69b10 fffffa80`00000008 : nt! ?? ::NNGAKEGL::`string'+0x28576
      fffff880`08bd0bb0 fffff800`0187a693 : 00000000`00000320 fffffa80`13d3fb50 fffffa80`18b69b10 00000000`ffffffff : nt!NtTerminateProcess+0x284
      fffff880`08bd0c20 00000000`76f6bdfa : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSystemServiceCopyEnd+0x13
      00000000`1a0ce108 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x76f6bdfa

      STACK_COMMAND: kb

      FOLLOWUP_NAME: MachineOwner

      IMAGE_VERSION:

      FAILURE_BUCKET_ID: X64_0xF4_jenkins-slave._IMAGE_csrss.exe

      BUCKET_ID: X64_0xF4_jenkins-slave._IMAGE_csrss.exe

      ANALYSIS_SOURCE: KM

      FAILURE_ID_HASH_STRING: km:x64_0xf4_jenkins-slave._image_csrss.exe

      FAILURE_ID_HASH:

      {8e7b1d81-a9a6-3c5f-d4e7-e491060513b5}

      Followup: MachineOwner

      Let me know if you need any further information.

        Attachments

          Issue Links

            Activity

            akumar8600 Amit Kumar added a comment -

            Can anyone please update on the issue. If somebody can help in fixing the same.

            @dbeck@cloudbees.com

            danielbeck Daniel Beck added a comment -

            Please stop assigning this issue.

            akumar8600 Amit Kumar added a comment -

            Thanks for the update. Will wait for the reply.

            oleg_nenashev Oleg Nenashev added a comment -

            The BSoD happens due to the jenkins-slave.exe, which terminates the critical process (csrss.exe).
            It is a duplicate of JENKINS-24453, which has been fixed in Jenkins 2.34 and then backported to 2.32.1

            Closing as a duplicate


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              akumar8600 Amit Kumar
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: