Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3677

Provide read-only view of project configuration

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Currently someone with a role that permits config on a project can view and modify any of the project's
      configuration settings. It would be desirable if there was a way to configure (or permit all) to view the
      project config settings without the ability to modify them. I'm fine with the same setting controlling this
      across all projects.

        Attachments

          Issue Links

            Activity

            mdonohue mdonohue added a comment -
                • Issue 3863 has been marked as a duplicate of this issue. ***
            dty Dean Yu added a comment -
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : dty
            Path:
            trunk/hudson/main/core/src/main/java/hudson/model/Item.java
            trunk/hudson/main/core/src/main/java/hudson/model/Job.java
            trunk/hudson/main/core/src/main/java/hudson/security/GlobalMatrixAuthorizationStrategy.java
            trunk/hudson/main/core/src/main/java/hudson/security/Permission.java
            trunk/hudson/main/core/src/main/resources/hudson/model/AbstractProject/sidepanel.jelly
            trunk/hudson/main/core/src/main/resources/hudson/model/Job/configure.jelly
            trunk/hudson/main/core/src/main/resources/hudson/model/Messages.properties
            trunk/hudson/main/test/src/test/java/hudson/security/ExtendedReadPermissionTest.java
            trunk/hudson/main/test/src/test/resources/hudson/security/ExtendedReadPermissionTest.zip
            http://fisheye4.cenqua.com/changelog/hudson/?cs=21626
            Log:
            JENKINS-3677 First pass at providing read-only access to project configuration.
            Defined a new permission, ExtendedRead, which can be enabled by specifying true
            for the system property hudson.security.ExtendedReadPermission. Granting job
            configuration permissions implies this permission.

            dty Dean Yu added a comment -

            Released Extended Read Permission plugin 1.0. This plugin, in conjunction with Hudson 1.324 or newer
            will give you this feature.

            mdonohue mdonohue added a comment -
                • Issue 4779 has been marked as a duplicate of this issue. ***
            mdonohue mdonohue added a comment -
                • Issue 4780 has been marked as a duplicate of this issue. ***
            arend_von_reinersdorff Arend v. Reinersdorff added a comment -

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              dmulter dmulter
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: