Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-36789

Jenkins hangs when build asp.net core application

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: core
    • Environment:
      OS: Windows Server 2008 R2 Standard (64-bit)
      Jenkins 2.14
      Jenkins installed as Windows Service and run under Local System account
    • Similar Issues:

      Description

      We have asp.net core web application and we use Jenkins as CI tool. The build step for our project in Jenkins consists of one step as 'Execute Windows batch command' with command dotnet.exe build "C:\Program Files (x86)\Jenkins\workspace\CustomerPortal Develop\src\CustomerPortal" --configuration Release --no-dependencies

      It hangs on build.

      Notice that, if i run this command via Command Prompt (cmd.exe) i get output:
      *Project CustomerPortal (.NETCoreApp,Version=v1.0) will be compiled because inputs were modified
      Compiling CustomerPortal for .NETCoreApp,Version=v1.0 Compilation succeeded.
      0 Warning(s)
      0 Error(s)
      Time elapsed 00:00:03.7759054*

      Any ideas?

        Attachments

          Activity

          danielbeck Daniel Beck added a comment -

          This is an issue tracker, not a support site. If you want to file this as a bug, show that it is one, and not e.g. caused by the dotnet.exe being called non-interactively, or by the user Jenkins is running as, etc.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            javid Javid Musayev
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: