Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-368

NullPointerException with m2 native projects in 1.87

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      M2 module builds seem to always fail under 1.87 with an exception like this one:

      started
      [] $ /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Home/bin/java
      -cp
      /opt/tomcat-hudson/webapps/hudson/WEB-INF/lib/maven-agent-1.87.jar:/opt/maven/core/boot/classworlds-1.1.jar
      hudson.maven.agent.Main /opt/maven
      /opt/tomcat-hudson/webapps/hudson/WEB-INF/lib/hudson-core-1.87.jar
      /opt/tomcat-hudson/webapps/hudson/WEB-INF/lib/maven-interceptor-1.87.jar
      channel started
      FATAL: null
      java.lang.NullPointerException
      at hudson.maven.agent.Main.launch(Main.java:65)
      at hudson.maven.MavenBuild$Builder.call(MavenBuild.java:127)
      at hudson.maven.MavenBuild$Builder.call(MavenBuild.java:105)
      at hudson.remoting.UserRequest.perform(UserRequest.java:57)
      at hudson.remoting.UserRequest.perform(UserRequest.java:22)
      at hudson.remoting.Request$2.run(Request.java:178)
      at
      edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:665)
      at
      edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:690)
      at java.lang.Thread.run(Thread.java:613)

      This did not happen in 1.85. See also:
      https://hudson.dev.java.net/servlets/ReadMsg?list=users&msgNo=1119 .

        Attachments

          Issue Links

            Activity

            kohsuke Kohsuke Kawaguchi added a comment -

            Fixed in 1.88.

            kohsuke Kohsuke Kawaguchi added a comment -
                • Issue 366 has been marked as a duplicate of this issue. ***

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              rsutphin rsutphin
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: