Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-36916

Delivery Pipeline not showing trigger button to start manual downstream project

    XMLWordPrintable

Details

    • Bug
    • Status: Open (View Workflow)
    • Major
    • Resolution: Unresolved
    • Amazon AWS Windows (Jenkins run directly, Java 8)
      Jenkins 2.15
      Delivery Pipeline plugin 0.9.12
      Build Pipeline plugin 1.5.3.1

    Description

      After installing and configuring Build and Delivery Pipeline plugins I cannot get Delivery Plugin View to show manual trigger ("play" buttons). The manual triggers are enabled in view setup, project are linked with manual.
      Is there any other condition to triggers button to appear?

      In the Build Pipeline View the jobs can be triggered manualy.

      Attachments

        Activity

          ryancox Ryan Cox added a comment -

          Any update on this issue? I am seeing similar behavior on some but not all workflow executions.

          ryancox Ryan Cox added a comment - Any update on this issue? I am seeing similar behavior on some but not all workflow executions.
          tommysdk Tommy Tynjä added a comment -

          martindobias ryancox ... and the jobs are configured with publisher / post-build action: "Build other projects (manual step)"? It should be sufficient to follow the instructions in the project README: https://github.com/Diabol/delivery-pipeline-plugin/#configuring-manually-triggered-jobs

          Is it possible to create a simple pipeline + view configuration to reproduce this which could aid in troubleshooting?

          tommysdk Tommy Tynjä added a comment - martindobias ryancox ... and the jobs are configured with publisher / post-build action: "Build other projects (manual step)"? It should be sufficient to follow the instructions in the project README: https://github.com/Diabol/delivery-pipeline-plugin/#configuring-manually-triggered-jobs Is it possible to create a simple pipeline + view configuration to reproduce this which could aid in troubleshooting?
          tommysdk Tommy Tynjä added a comment -

          Also, does the issue appear with the latest released version of the Delivery Pipeline Plugin (1.0.0)?

          tommysdk Tommy Tynjä added a comment - Also, does the issue appear with the latest released version of the Delivery Pipeline Plugin (1.0.0)?
          tommysdk Tommy Tynjä added a comment -

          martindobias ryancox Could you please provide some additional information on this?

          tommysdk Tommy Tynjä added a comment - martindobias ryancox Could you please provide some additional information on this?
          jorgebo10 jorge bo added a comment -

          I'm experiencing the same problem with DPPv1.0.2 and BDPv1.5.7.1.

          jorgebo10 jorge bo added a comment - I'm experiencing the same problem with DPPv1.0.2 and BDPv1.5.7.1.
          tommysdk Tommy Tynjä added a comment -

          jorgebo10 could you please provide a reproducing test case (Junit or sample pipeline setup, config.xml etc)?

          tommysdk Tommy Tynjä added a comment - jorgebo10 could you please provide a reproducing test case (Junit or sample pipeline setup, config.xml etc)?

          People

            patbos Patrik Boström
            martindobias Martin Dobias
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated: