Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-37379

Some real-time favorite card statuses are not accurate

    XMLWordPrintable

Details

    • 1.0-pre-beta-1, 1.0-beta-1, pacific, atlantic, 1.0-b05/b-06

    Description

      There are some edge cases related to real-time card updates for the Favorites Dashboard which require some SSE changes to adequately address:

      1. Pipeline and Multibranch Pipeline jobs will dispatch "job_started" events as soon as they are run, even if all executors are currently busy. This results in the favorite going into RUNNING status when the user would expect the job is really QUEUED. Tracked by JENKINS-37340
      2. Due to the above behavior, repeated runs of the same pipeline or MB pipeline lead to misleading behavior in the UI. The card will initially reflect the RUNNING state, but after the first job completes it will enter the SUCCESS or FAILED state and remain as such while other jobs are running. This is because no further events are received as the subsequent job runs are actually started.

      Attachments

        Issue Links

          Activity

            cliffmeyers Cliff Meyers created issue -
            cliffmeyers Cliff Meyers made changes -
            Field Original Value New Value
            Epic Link JENKINS-35761 [ 171656 ]
            cliffmeyers Cliff Meyers made changes -
            Link This issue is blocked by JENKINS-37340 [ JENKINS-37340 ]
            jamesdumay James Dumay made changes -
            Sprint 1.0-pre-beta-1 [ 86 ]
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            jamesdumay James Dumay made changes -
            Priority Minor [ 4 ] Major [ 3 ]
            jamesdumay James Dumay made changes -
            Sprint 1.0-pre-beta-1 [ 86 ] 1.0-pre-beta-1, 1.0-beta-1 [ 86, 96 ]
            jamesdumay James Dumay made changes -
            Rank Ranked lower
            michaelneale Michael Neale made changes -
            Link This issue is blocked by JENKINS-37340 [ JENKINS-37340 ]
            michaelneale Michael Neale made changes -
            Link This issue blocks JENKINS-37340 [ JENKINS-37340 ]
            cliffmeyers Cliff Meyers made changes -
            Link This issue blocks JENKINS-37340 [ JENKINS-37340 ]
            cliffmeyers Cliff Meyers made changes -
            Link This issue is related to JENKINS-37340 [ JENKINS-37340 ]
            cliffmeyers Cliff Meyers made changes -
            Link This issue is blocked by JENKINS-37763 [ JENKINS-37763 ]
            jamesdumay James Dumay made changes -
            Sprint 1.0-pre-beta-1, 1.0-beta-1 [ 86, 96 ] 1.0-pre-beta-1, 1.0-beta-1, 1.0-b05/b-06 [ 86, 96, 111 ]
            jamesdumay James Dumay made changes -
            Sprint 1.0-pre-beta-1, 1.0-beta-1, 1.0-b05/b-06 [ 86, 96, 111 ] 1.0-pre-beta-1, 1.0-beta-1, 26-september, 1.0-b05/b-06 [ 86, 96, 101, 111 ]
            cliffmeyers Cliff Meyers made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            cliffmeyers Cliff Meyers made changes -
            Link This issue is blocked by JENKINS-38540 [ JENKINS-38540 ]
            kzantow Keith Zantow added a comment -

            cliffmeyers when you have time, please check PR 543 to see if it fixes this issue for you

            kzantow Keith Zantow added a comment - cliffmeyers when you have time, please check PR 543 to see if it fixes this issue for you
            michaelneale Michael Neale made changes -
            Sprint 1.0-pre-beta-1, 1.0-beta-1, pacific, 1.0-b05/b-06 [ 86, 96, 101, 111 ] 1.0-pre-beta-1, 1.0-beta-1, pacific, atlantic, 1.0-b05/b-06 [ 86, 96, 101, 106, 111 ]
            michaelneale Michael Neale made changes -
            Status In Progress [ 3 ] Open [ 1 ]
            cliffmeyers Cliff Meyers made changes -
            Link This issue is related to JENKINS-37340 [ JENKINS-37340 ]
            jamesdumay James Dumay made changes -
            Sprint 1.0-pre-beta-1, 1.0-beta-1, pacific, atlantic, 1.0-b05/b-06 [ 86, 96, 101, 106, 111 ] 1.0-pre-beta-1, 1.0-beta-1, pacific, atlantic, 1.0-b05/b-06, indian [ 86, 96, 101, 106, 111, 126 ]
            jamesdumay James Dumay made changes -
            Rank Ranked lower
            jamesdumay James Dumay made changes -
            Priority Major [ 3 ] Minor [ 4 ]
            jamesdumay James Dumay made changes -
            Sprint 1.0-pre-beta-1, 1.0-beta-1, pacific, atlantic, 1.0-b05/b-06, indian [ 86, 96, 101, 106, 111, 126 ] 1.0-pre-beta-1, 1.0-beta-1, pacific, atlantic, 1.0-b05/b-06 [ 86, 96, 101, 106, 111 ]
            jamesdumay James Dumay made changes -
            Sprint 1.0-pre-beta-1, 1.0-beta-1, pacific, atlantic, 1.0-b05/b-06 [ 86, 96, 101, 106, 111 ] 1.0-pre-beta-1, 1.0-beta-1, pacific, atlantic, 1.0-b05/b-06, arctic [ 86, 96, 101, 106, 111, 131 ]
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            jamesdumay James Dumay made changes -
            Sprint 1.0-pre-beta-1, 1.0-beta-1, pacific, atlantic, 1.0-b05/b-06, arctic [ 86, 96, 101, 106, 111, 131 ] 1.0-pre-beta-1, 1.0-beta-1, pacific, atlantic, 1.0-b05/b-06 [ 86, 96, 101, 106, 111 ]
            jamesdumay James Dumay made changes -
            Rank Ranked lower
            jamesdumay James Dumay made changes -
            Assignee Cliff Meyers [ cliffmeyers ]
            jamesdumay James Dumay made changes -
            Sprint 1.0-pre-beta-1, 1.0-beta-1, pacific, atlantic, 1.0-b05/b-06 [ 86, 96, 101, 106, 111 ] 1.0-pre-beta-1, 1.0-beta-1, pacific, atlantic, 1.0-b05/b-06, 1.1 [ 86, 96, 101, 106, 111, 251 ]
            jamesdumay James Dumay made changes -
            Rank Ranked lower
            jamesdumay James Dumay made changes -
            Sprint 1.0-pre-beta-1, 1.0-beta-1, pacific, atlantic, 1.0-b05/b-06, 1.1 [ 86, 96, 101, 106, 111, 251 ] 1.0-pre-beta-1, 1.0-beta-1, pacific, atlantic, 1.0-b05/b-06, up next [ 86, 96, 101, 106, 111, 171 ]
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            jamesdumay James Dumay made changes -
            Sprint 1.0-pre-beta-1, 1.0-beta-1, pacific, atlantic, 1.0-b05/b-06, up next [ 86, 96, 101, 106, 111, 171 ] 1.0-pre-beta-1, 1.0-beta-1, pacific, atlantic, 1.0-b05/b-06 [ 86, 96, 101, 106, 111 ]
            jamesdumay James Dumay made changes -
            Sprint 1.0-pre-beta-1, 1.0-beta-1, pacific, atlantic, 1.0-b05/b-06 [ 86, 96, 101, 106, 111 ] 1.0-pre-beta-1, 1.0-beta-1, pacific, atlantic, 1.0-b05/b-06, 1.1 [ 86, 96, 101, 106, 111, 251 ]
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            jamesdumay James Dumay made changes -
            Sprint 1.0-pre-beta-1, 1.0-beta-1, pacific, atlantic, 1.0-b05/b-06, Blue Ocean up next [ 86, 96, 101, 106, 111, 251 ] 1.0-pre-beta-1, 1.0-beta-1, pacific, atlantic, 1.0-b05/b-06 [ 86, 96, 101, 106, 111 ]
            jamesdumay James Dumay made changes -
            Rank Ranked lower
            jamesdumay James Dumay added a comment -

            cliffmeyers is this one still a problem or should we close? I haven't heard any complaints.

            jamesdumay James Dumay added a comment - cliffmeyers is this one still a problem or should we close? I haven't heard any complaints.
            jamesdumay James Dumay made changes -
            Resolution Postponed [ 6 ]
            Status Open [ 1 ] Resolved [ 5 ]
            cliffmeyers Cliff Meyers added a comment -

            This is still a valid bug, although might be a bit of an edge case. Repro steps:

            1. Favorite a job and leave dashboard open
            2. Open the job in classic
            3. Run it, wait a few seconds, and run again
            4. Abort the first run

            Expected behavior:

            • Job shows as "running"

            Actual behavior:

            • Job shows as "aborted"
            cliffmeyers Cliff Meyers added a comment - This is still a valid bug, although might be a bit of an edge case. Repro steps: Favorite a job and leave dashboard open Open the job in classic Run it, wait a few seconds, and run again Abort the first run Expected behavior: Job shows as "running" Actual behavior: Job shows as "aborted"
            cliffmeyers Cliff Meyers added a comment -

            It's not a bug just in this narrow scenario of course - any situation where there are concurrent runs of the same job and one is aborted / successful / failure will update the favorite card even though the other run is still in-progress.

            cliffmeyers Cliff Meyers added a comment - It's not a bug just in this narrow scenario of course - any situation where there are concurrent runs of the same job and one is aborted / successful / failure will update the favorite card even though the other run is still in-progress.
            jamesdumay James Dumay made changes -
            Resolution Postponed [ 6 ]
            Status Resolved [ 5 ] Reopened [ 4 ]

            People

              Unassigned Unassigned
              cliffmeyers Cliff Meyers
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated: