Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-37879

Jenkins NUnit plugin 0.18 gives an error while reading nunit result xml file

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Duplicate
    • nunit-plugin
    • None
    • Windows

    Description

      When the Nunit plugin tries to read the test result xml file, it gives the below error.

      Results (nunit3) saved as TestResult.xml
      Recording NUnit tests results
      ERROR: Step ‘Publish NUnit test result report’ aborted due to exception:
      java.io.IOException: Could not transform the NUnit report. Please report this issue to the plugin author
      at hudson.plugins.nunit.NUnitArchiver.invoke(NUnitArchiver.java:71)
      at hudson.plugins.nunit.NUnitArchiver.invoke(NUnitArchiver.java:29)
      at hudson.FilePath.act(FilePath.java:1018)
      at hudson.FilePath.act(FilePath.java:996)
      at hudson.plugins.nunit.NUnitPublisher.perform(NUnitPublisher.java:153)
      at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:779)
      at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:720)
      at hudson.model.Build$BuildExecution.post2(Build.java:185)
      at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:665)
      at hudson.model.Run.execute(Run.java:1766)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:98)
      at hudson.model.Executor.run(Executor.java:410)
      Caused by: org.xml.sax.SAXParseException; systemId: file:/C:/Users/2554/.jenkins/workspace/TestProject/temporary-junit-reports/temp-junit.xml; lineNumber: 2; columnNumber: 3; Content is not allowed in prolog.
      at com.sun.org.apache.xerces.internal.parsers.DOMParser.parse(Unknown Source)
      at com.sun.org.apache.xerces.internal.jaxp.DocumentBuilderImpl.parse(Unknown Source)
      at javax.xml.parsers.DocumentBuilder.parse(Unknown Source)
      at hudson.plugins.nunit.NUnitReportTransformer.splitJUnitFile(NUnitReportTransformer.java:102)
      at hudson.plugins.nunit.NUnitReportTransformer.transform(NUnitReportTransformer.java:72)
      at hudson.plugins.nunit.NUnitArchiver.invoke(NUnitArchiver.java:66)
      ... 13 more
      Finished: FAILURE

      Attachments

        Issue Links

          Activity

            vijaynag vijay nag created issue -

            It seems to complain about the report contents. Could you attach an example, so that I can try to reproduce it, please?

            kinow Bruno P. Kinoshita added a comment - It seems to complain about the report contents. Could you attach an example, so that I can try to reproduce it, please?
            vijaynag vijay nag made changes -
            Field Original Value New Value
            Attachment TestResult.xml [ 33785 ]
            vijaynag vijay nag added a comment -

            Attached the test result xml file. Thanks.

            vijaynag vijay nag added a comment - Attached the test result xml file. Thanks.

            Thanks vijaynag!

            kinow Bruno P. Kinoshita added a comment - Thanks vijaynag !
            slide_o_mix Alex Earl added a comment -

            Looks like the test result is from nunit3, which I don't think is currently supported right now (I could be wrong)

            slide_o_mix Alex Earl added a comment - Looks like the test result is from nunit3, which I don't think is currently supported right now (I could be wrong)
            slide_o_mix Alex Earl made changes -
            Link This issue duplicates JENKINS-27906 [ JENKINS-27906 ]
            slide_o_mix Alex Earl made changes -
            Assignee Bruno P. Kinoshita [ kinow ] Alex Earl [ slide_o_mix ]
            slide_o_mix Alex Earl made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Closed [ 6 ]

            People

              slide_o_mix Alex Earl
              vijaynag vijay nag
              Votes:
              4 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: