Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-37908

docker 1.12 swarm support for docker-plugin

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Does the Docker Plugin support connecting a Swarm using docker engine 1.12+ ?

      I cannot connect to the swarm as a new "Cloud" and am seeing this error:Caused by: shaded.org.apache.http.ProtocolException: The server failed to respond with a valid HTTP response

      I could successfully connect Swarm using docker engine 1.10:

      Version = swarm/1.2.4

        Attachments

          Activity

          Hide
          ndeloof Nicolas De Loof added a comment -

          swarm mode isn't supported (yet)

          I plan to investigate adding support, but this one introduce some significant restrictions on flexibility we have ot setup containers.

          you can rely on standalone docker swarm as a working alternative

           

          Show
          ndeloof Nicolas De Loof added a comment - swarm mode isn't supported (yet) I plan to investigate adding support, but this one introduce some significant restrictions on flexibility we have ot setup containers. you can rely on standalone docker swarm as a working alternative  

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            darcarys Gaurav Swaroop
            Votes:
            5 Vote for this issue
            Watchers:
            6 Start watching this issue

              Dates

              Created:
              Updated: