Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-38107

Failed to dynamically deploy this plugin

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      When trying to upload sauce connect plugin(.hpi) file I get the below error. Trying to upload 1.155 v for sauceconnect

      Failure -
      java.io.IOException: Failed to dynamically deploy this plugin
      at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:1328)
      at hudson.model.UpdateCenter$DownloadJob.run(UpdateCenter.java:1126)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      at java.util.concurrent.FutureTask.run(FutureTask.java:262)
      at hudson.remoting.AtmostOneThreadExecutor$Worker.run(AtmostOneThreadExecutor.java:110)
      at java.lang.Thread.run(Thread.java:745)
      Caused by: java.io.IOException: Failed to install sauce-ondemand plugin
      at hudson.PluginManager.dynamicLoad(PluginManager.java:474)
      at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:1324)
      ... 5 more
      Caused by: java.io.IOException: Dependency workflow-step-api (1.15), workflow-basic-steps (1.15), workflow-cps (1.15), workflow-job (1.15) doesn't exist
      at hudson.PluginWrapper.resolvePluginDependencies(PluginWrapper.java:480)
      at hudson.PluginManager.dynamicLoad(PluginManager.java:464)
      ... 6 more

        Attachments

          Activity

          Hide
          halkeye Gavin Mogan added a comment -

          Hi Suprinder Pujji

          I assume you are uploading the hpi manually and not using update center?
          if you are doing that, it won't automatically pull in any dependencies.
          So as it says by the "Caused by" section, you'll also need to install workflow-step-api, workflow-basic-steps, workflow-cps, workflow-job

          Have you tried the jenkins cli interface (https://wiki.jenkins-ci.org/display/JENKINS/Jenkins+CLI)? I think it might pull down deps for you, otherwise you'll have to do it manually or use update center.

          Show
          halkeye Gavin Mogan added a comment - Hi Suprinder Pujji I assume you are uploading the hpi manually and not using update center? if you are doing that, it won't automatically pull in any dependencies. So as it says by the "Caused by" section, you'll also need to install workflow-step-api, workflow-basic-steps, workflow-cps, workflow-job Have you tried the jenkins cli interface ( https://wiki.jenkins-ci.org/display/JENKINS/Jenkins+CLI)? I think it might pull down deps for you, otherwise you'll have to do it manually or use update center.
          Hide
          suprinder Suprinder Pujji added a comment -

          Thanks Gavin. How to get to update center ? Also that link you shared does not render a page. Wondering whats wrong

          Show
          suprinder Suprinder Pujji added a comment - Thanks Gavin. How to get to update center ? Also that link you shared does not render a page. Wondering whats wrong
          Hide
          halkeye Gavin Mogan added a comment -

          jira added extra characters. Try https://wiki.jenkins-ci.org/display/JENKINS/Jenkins+CLI

          Update center is jenkins plugin management system

          Jenkins -> Manage Jenkins -> Manage Plugins -> Updates (pre selected)

          This may/probably won't work if your firewall is highly restrictive.

          Show
          halkeye Gavin Mogan added a comment - jira added extra characters. Try https://wiki.jenkins-ci.org/display/JENKINS/Jenkins+CLI Update center is jenkins plugin management system Jenkins -> Manage Jenkins -> Manage Plugins -> Updates (pre selected) This may/probably won't work if your firewall is highly restrictive.
          Hide
          suprinder Suprinder Pujji added a comment - - edited

          Yeah so thats what I do. But the updates page is totally empty could be because of the reason you mentioned. SO I went to Advanced section and tried to upload the .hpi file via Upload when I get the error. So Ill try the new url you shared thanks Gavin

          Show
          suprinder Suprinder Pujji added a comment - - edited Yeah so thats what I do. But the updates page is totally empty could be because of the reason you mentioned. SO I went to Advanced section and tried to upload the .hpi file via Upload when I get the error. So Ill try the new url you shared thanks Gavin
          Hide
          halkeye Gavin Mogan added a comment -

          Yea, sorry, its a little outside what support I can provide.

          You can also try clicking the "Check now" button on the plugins page, and see if it downloads new data.
          Maybe try "Use browser for metadata download" from the global security page, but i think that has risks

          You can also manually download dependency versions @ https://updates.jenkins-ci.org/download/plugins/

          Show
          halkeye Gavin Mogan added a comment - Yea, sorry, its a little outside what support I can provide. You can also try clicking the "Check now" button on the plugins page, and see if it downloads new data. Maybe try "Use browser for metadata download" from the global security page, but i think that has risks You can also manually download dependency versions @ https://updates.jenkins-ci.org/download/plugins/
          Hide
          suprinder Suprinder Pujji added a comment -

          No Problem Gavin. Thanks. So that is what I was doing. Manually downloaded the plugin and it just downloads the .hpi file I assume it has everything that is required. Then I upload it via the Advanced PAge Upload Plugin option when I get the above error.

          Show
          suprinder Suprinder Pujji added a comment - No Problem Gavin. Thanks. So that is what I was doing. Manually downloaded the plugin and it just downloads the .hpi file I assume it has everything that is required. Then I upload it via the Advanced PAge Upload Plugin option when I get the above error.
          Hide
          halkeye Gavin Mogan added a comment -

          Yea you'll just have to install the other plugins as well

          I'm going to close this issue now

          Show
          halkeye Gavin Mogan added a comment - Yea you'll just have to install the other plugins as well I'm going to close this issue now

            People

            Assignee:
            halkeye Gavin Mogan
            Reporter:
            suprinder Suprinder Pujji
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: