Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-388

java.io.NotSerializableException: hudson.scm.browsers.ViewSVN

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      after upgrading to version 1.90 I got following exception during running on slave:
      FATAL: remote file operation failed
      hudson.util.IOException2: remote file operation failed
      at hudson.FilePath.act(FilePath.java:229)
      at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:252)
      at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:230)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:280)
      at hudson.model.AbstractBuild$AbstractRunner.checkout(AbstractBuild.java:150)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:116)
      at hudson.model.Run.run(Run.java:544)
      at hudson.model.Build.run(Build.java:99)
      at hudson.model.Executor.run(Executor.java:61)
      Caused by: java.io.IOException: Unable to serialize hudson.FilePath$2@1afc1de
      at hudson.remoting.UserRequest.serialize(UserRequest.java:84)
      at hudson.remoting.UserRequest.<init>(UserRequest.java:29)
      at hudson.remoting.Channel.call(Channel.java:240)
      at hudson.FilePath.act(FilePath.java:216)
      ... 8 more
      Caused by: java.io.NotSerializableException: hudson.scm.browsers.ViewSVN
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1075)
      at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1369)
      at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1341)
      at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1284)
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1073)
      at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1369)
      at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1341)
      at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1284)
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1073)
      at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1369)
      at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1341)
      at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1284)
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1073)
      at java.io.ObjectOutputStream.writeObject(ObjectOutputStream.java:291)
      at hudson.remoting.UserRequest.serialize(UserRequest.java:81)
      ... 11 more

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          Ouch!

          I never seem to learn a lesson. Never, ever, release a new version without first
          giving it some soak time in my production system...

          Fixed in 1.91. Plan to release today.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            ramazanyich2 ramazanyich2
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: