Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-38891

Pull Requests page is confusing

    XMLWordPrintable

Details

    Description

      The current view for PRs is a bit confusing (for me at least).

      Is build 7 (in the screenshot) building all that commits? Why are there in different lines if it is the same build? Am I missing something?

      Screenshot taken from jenkins on jenkins instance.

      Attachments

        Issue Links

          Activity

            amuniz Antonio Muñiz created issue -
            amuniz Antonio Muñiz made changes -
            Field Original Value New Value
            Description The current view for PRs is a bit confusing (for me at least).

            Is build 8 (in the screenshot) building all that commits? Why are there in different lines if it is the same build? Am I missing something?

            Screenshot taken from [jenkins on jenkins instance|https://ci.jenkins.io/blue/organizations/jenkins/Core%2Fjenkins/pr].
            The current view for PRs is a bit confusing (for me at least).

            Is build 7 (in the screenshot) building all that commits? Why are there in different lines if it is the same build? Am I missing something?

            Screenshot taken from [jenkins on jenkins instance|https://ci.jenkins.io/blue/organizations/jenkins/Core%2Fjenkins/pr].

            jamesdumay and brody please have a look

            tscherler Thorsten Scherler added a comment - jamesdumay and brody please have a look
            cliffmeyers Cliff Meyers added a comment -

            My 2 cents: probably needs an identifier for the pull request ID but really the branch name would probably be the most useful.

            cliffmeyers Cliff Meyers added a comment - My 2 cents: probably needs an identifier for the pull request ID but really the branch name would probably be the most useful.

            Yeah, I agree cliffmeyers

            tscherler Thorsten Scherler added a comment - Yeah, I agree cliffmeyers
            michaelneale Michael Neale added a comment -

            ah yes, this is to make you appear more productive and have more pull requests yeah this does seem wrong. I think what happens is that when there are multiple commits from multiple people they show up like this. amuniz can you link to some actual PRs this lists, so we can confirm?

            michaelneale Michael Neale added a comment - ah yes, this is to make you appear more productive and have more pull requests yeah this does seem wrong. I think what happens is that when there are multiple commits from multiple people they show up like this. amuniz can you link to some actual PRs this lists, so we can confirm?
            tscherler Thorsten Scherler added a comment - michaelneale https://ci.jenkins.io/blue/organizations/jenkins/Core%2Fjenkins/pr
            michaelneale Michael Neale added a comment -

            tscherler you mentioned that you didn't think was a bug - can you explain what is going on? (I am confused)

            michaelneale Michael Neale added a comment - tscherler you mentioned that you didn't think was a bug - can you explain what is going on? (I am confused)

            michaelneale it is not a bug since AFAIR what we see is the original design, but could not found the old ticket tough. Anyway IMO we should simply add another column so we show the branch of the PR

            tscherler Thorsten Scherler added a comment - michaelneale it is not a bug since AFAIR what we see is the original design, but could not found the old ticket tough. Anyway IMO we should simply add another column so we show the branch of the PR
            michaelneale Michael Neale added a comment -

            tscherler thanks - I will bug james about it when he is back (this isn't something I have looked at much), as it seems not what I would expect either.

            michaelneale Michael Neale added a comment - tscherler thanks - I will bug james about it when he is back (this isn't something I have looked at much), as it seems not what I would expect either.
            cliffmeyers Cliff Meyers added a comment -

            These are the current columns (in case the screenie doesn't make it clear): last build's status, build number, last commit message, author, last build completed, (action buttons)

            cliffmeyers Cliff Meyers added a comment - These are the current columns (in case the screenie doesn't make it clear): last build's status, build number, last commit message, author, last build completed, (action buttons)
            jamesdumay James Dumay added a comment -

            What I think we should do here is drop the "Latest build" column and replace with a "Pull Request" ID and "Branch" column. WDYT?

            jamesdumay James Dumay added a comment - What I think we should do here is drop the "Latest build" column and replace with a "Pull Request" ID and "Branch" column. WDYT?
            michaelneale Michael Neale made changes -
            Description The current view for PRs is a bit confusing (for me at least).

            Is build 7 (in the screenshot) building all that commits? Why are there in different lines if it is the same build? Am I missing something?

            Screenshot taken from [jenkins on jenkins instance|https://ci.jenkins.io/blue/organizations/jenkins/Core%2Fjenkins/pr].


            The current view for PRs is a bit confusing (for me at least).

            Is build 7 (in the screenshot) building all that commits? Why are there in different lines if it is the same build? Am I missing something?

            Screenshot taken from [jenkins on jenkins instance|https://ci.jenkins.io/blue/organizations/jenkins/Core%2Fjenkins/pr].
            michaelneale Michael Neale added a comment -

            Thanks Antonio! I have rewritten this as a fresh ticket with actions to take

            michaelneale Michael Neale added a comment - Thanks Antonio! I have rewritten this as a fresh ticket with actions to take
            michaelneale Michael Neale made changes -
            Link This issue duplicates JENKINS-39202 [ JENKINS-39202 ]
            michaelneale Michael Neale made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Closed [ 6 ]

            People

              Unassigned Unassigned
              amuniz Antonio Muñiz
              Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: