Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-39698

Masking of password is not happening

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      i am using jenkins masking plugin to mask the passwords.

      I have an user (i054564) defined in credentials as username/password type

      The user name /password is defined in the bindings section as well as in the mask password subsection of Build environment section.So whenever i am using that user/password in my build job as a variable, the password is not masked and logged in the console

      Some snapshots have been attached to depict the problem

      Snapshot -1 Build specific settings
      Snapshot -2 Credentials settings
      Snapshot -3 Manage Jenkins Mask password settings

      [![enter image description here][1]][1]

      [![enter image description here][2]][2]
      [![enter image description here][3]][3]

      Strange thing is initially it works and then after 2-3 builds it stops working.

      please let me know if you need any further details

      best Regards,

      Saurav

        Attachments

          Activity

          Hide
          oleg_nenashev Oleg Nenashev added a comment -

          Please re-check the issue with 2.10.1

          Show
          oleg_nenashev Oleg Nenashev added a comment - Please re-check the issue with 2.10.1
          Hide
          oleg_nenashev Oleg Nenashev added a comment -

          I suppose it's fixed now. If no, please reopen

          Show
          oleg_nenashev Oleg Nenashev added a comment - I suppose it's fixed now. If no, please reopen

            People

            Assignee:
            oleg_nenashev Oleg Nenashev
            Reporter:
            sauravs saurav sarkar
            Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: