Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-398

Shared workspace between jobs or different actions in the same job?

    XMLWordPrintable

Details

    • Improvement
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Duplicate
    • core
    • None
    • Platform: All, OS: All

    Description

      A common issue building projects is to have several actions done on the same
      project.

      Imagine you have a project A and you want to add a Subversion hook so you can
      compile and run tests every time you make a commit. Also you want to be able to
      generate a web site every night.

      This scenario could be interpreted as project A build with two build triggers, a
      default one to just compile and test and another one to have project's site
      generated, which is launched, i.e., everyday at 2a.m.

      Nowadays if you you want this feature done with Hudson it´s necessary to define
      two separated jobs, each one with its own copy of the project.

      If you have many different actions on the same project you have so many jobs in
      Hudson each one with its on workspace copy.

      Why not share this workspace?

      Attachments

        Issue Links

          Activity

            I think issue #682 covers this issue, so consolidating.

                • This issue has been marked as a duplicate of 682 ***
            kohsuke Kohsuke Kawaguchi added a comment - I think issue #682 covers this issue, so consolidating. This issue has been marked as a duplicate of 682 ***

            People

              Unassigned Unassigned
              pablomuniz pablomuniz
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: