Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4018

"Tag this Build" fails for 1.311+ with SVN Plugin

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • subversion-plugin
    • None
    • Platform: All, OS: Windows XP

    Description

      We are running with Subversion SCM and it looks like the tagging feature no
      longer works ("Tag this build".) After a clean restart of Hudson, below is the
      error message you get the first time you try to tag. Subsequent attempts don't
      display anything, it just resets the page. In neither case does the tag actually
      take place in SVN.

      I have tested this in 1.311 as well as 1.314 and the problem continues to
      exists. I haven't tried prior to 1.311 since I don't want to downgrade SVNkit in
      case there's workspace working copy version problems with the downgrade. If I
      had to guess i presume it's something to do with SVNkit upgrade of the new
      isolation of the SVN support in the recent builds?

      ====
      Tagging svn://.../trunk (rev.23689) to svn://.../tags/test

      tried to access field hudson.scm.AbstractScmTagAction.build from class
      hudson.scm.SubversionTagAction$TagWorkerThread

      java.lang.IllegalAccessError: tried to access field
      hudson.scm.AbstractScmTagAction.build from class
      hudson.scm.SubversionTagAction$TagWorkerThread
      at
      hudson.scm.SubversionTagAction$TagWorkerThread.perform(SubversionTagAction.java:204)
      at hudson.model.TaskThread.run(TaskThread.java:116)

      Completed
      ====

      Attachments

        Issue Links

          Activity

            mindless Alan Harder added a comment -
                • Issue 4262 has been marked as a duplicate of this issue. ***
            mindless Alan Harder added a comment - Issue 4262 has been marked as a duplicate of this issue. ***
            kame kame added a comment -
                • Issue 4200 has been marked as a duplicate of this issue. ***
            kame kame added a comment - Issue 4200 has been marked as a duplicate of this issue. ***

            This is released as Subversion plugin 1.5 and will be Hudson 1.321.

            kohsuke Kohsuke Kawaguchi added a comment - This is released as Subversion plugin 1.5 and will be Hudson 1.321.
            kame kame added a comment -

            Works with 1.320 upgrading the Subversion Plugin "by hand". Not sure it's
            recommended though.

            kame kame added a comment - Works with 1.320 upgrading the Subversion Plugin "by hand". Not sure it's recommended though.
            hoob hoob added a comment -

            Confirmed fixed with Hudson 1.321; thanks.

            hoob hoob added a comment - Confirmed fixed with Hudson 1.321; thanks.

            People

              Unassigned Unassigned
              hoob hoob
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: