Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4056

Add ability to warn/notify users of major changes to a plugin

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Add the ability for plugin releases to state that they have major changes in
      comparison to the installed version of the plugin - i.e., major changes in
      functionality or configuration. It should (theoretically) be possible to have a
      record of which version is the first one to be fully compatible, etc.

        Attachments

          Activity

          Hide
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : abayer
          Path:
          trunk/hudson/main/core/src/main/java/hudson/model/UpdateCenter.java
          trunk/hudson/main/core/src/main/resources/hudson/PluginManager/table.jelly
          trunk/hudson/main/war/resources/css/style.css
          trunk/hudson/tools/maven-hpi-plugin/src/main/java/org/jvnet/hudson/maven/plugins/hpi/AbstractHpiMojo.java
          http://fisheye4.cenqua.com/changelog/hudson/?cs=21097
          Log:
          [FIXED JENKINS-4056] Added support for marking a new plugin version as configuration-incompatible with previous versions - see http://wiki.jenkins-ci.org/display/JENKINS/Marking+a+new+plugin+version+as+incompatible+with+older+versions

          Show
          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : abayer Path: trunk/hudson/main/core/src/main/java/hudson/model/UpdateCenter.java trunk/hudson/main/core/src/main/resources/hudson/PluginManager/table.jelly trunk/hudson/main/war/resources/css/style.css trunk/hudson/tools/maven-hpi-plugin/src/main/java/org/jvnet/hudson/maven/plugins/hpi/AbstractHpiMojo.java http://fisheye4.cenqua.com/changelog/hudson/?cs=21097 Log: [FIXED JENKINS-4056] Added support for marking a new plugin version as configuration-incompatible with previous versions - see http://wiki.jenkins-ci.org/display/JENKINS/Marking+a+new+plugin+version+as+incompatible+with+older+versions
          Hide
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : kohsuke
          Path:
          trunk/www/changelog.html
          http://fisheye4.cenqua.com/changelog/hudson/?cs=21257
          Log:
          JENKINS-4056 recording r21097.

          Show
          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : kohsuke Path: trunk/www/changelog.html http://fisheye4.cenqua.com/changelog/hudson/?cs=21257 Log: JENKINS-4056 recording r21097.

            People

            Assignee:
            abayer Andrew Bayer
            Reporter:
            abayer Andrew Bayer
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: