Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4070

"Edit Description" saves changes in wrong place for the default view

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Hudson 1.316 introduced the ability to designate a default view (previously, the
      default view was fixed as the "All" view).

      There is a bug in the implementation:
      1) Set the default view to something other than "All".
      2) Go to the default view and click "Edit description".
      3) Make a change to the description, then click "submit" to save it.
      The changes are saved against the "All" view, rather than the view you are
      editing. This is incorrect.

        Attachments

          Issue Links

            Activity

            mwebber Matthew Webber added a comment -

            I just noticed an additional, related bug.

            1) I have a number of views - let's say I have ALL, MYVIEW1, MYVIEW2, with
            MYVIEW1 as the default view.
            2) If I click on the view tab for MYVIEW2 (non default), I see that view
            displayed, and in the top left corner of the page I see the breadcrumb trail
            "Hudson >> MYVIEW2". All correct.
            3) Let's say that within MYVIEW2 there is MYJOB. If I click on that, I see the
            page for the job, and in the top left corner of the page I see the breadcrumb
            trail "Hudson >> MYVIEW2 >> MYJOB". All correct.

            4) However, if I click on the view tab for MYVIEW1 (default), I see that view
            displayed, and in the top left corner of the page I see a breadcrumb trail or
            just "Hudson", rather than "Hudson >> MYVIEW1" which is what I expected.
            5) Let's say that within MYVIEW1 there is MYJOB. If I click on that, I see the
            page for the job, and in the top left corner of the page I see the breadcrumb
            trail "Hudson >> MYJOB", rather than "Hudson >> MYVIEW2 >> MYJOB" which is what
            I expected.

            This is not as much of a problem as the first bug reported in this ticket, but
            it's still unexpected behavior.

            It looks to me as though the implementation of the "default" view, and least in
            part, treats it as a synonym of the "All" view, even though it is not really.

            mindless Alan Harder added a comment -

            The 2nd comment is correct behavior, right? When you make MYVIEW1 the default
            view, then the "Hudson" link at the start of the breadcrumb IS for MYVIEW1.. so
            MYVIEW1 shouldn't be separately listed in the breadcrumb. The thing to check is
            when you go to All view, does it show Hudson >> All >> ... Since All is
            non-default, then it needs to show it... makes sense?

            mwebber Matthew Webber added a comment -

            Agreed, the 2nd comment, which I claimed as a bug, is on reflection correct
            behaviour.

            mindless Alan Harder added a comment -

            started

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : mindless
            Path:
            trunk/hudson/main/core/src/main/java/hudson/model/AllView.java
            trunk/hudson/main/core/src/main/java/hudson/model/Hudson.java
            trunk/hudson/main/core/src/main/resources/hudson/model/AbstractModelObject/descriptionForm.jelly
            trunk/www/changelog.html
            http://fisheye4.cenqua.com/changelog/hudson/?cs=20183
            Log:
            [FIXED JENKINS-4070] Edit Description worked incorrectly when default view
            is changed from All jobs.

            mindless Alan Harder added a comment -
                • Issue 4122 has been marked as a duplicate of this issue. ***

              People

              Assignee:
              mindless Alan Harder
              Reporter:
              mwebber Matthew Webber
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: