Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-40772

plugin not compatible to folders plugin version 4.10 and older

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: prioritysorter-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.580.3
      Folders plugin 4.10
    • Similar Issues:

      Description

      The priority sorter plugin is currently built againt Jenkins 1.580. But also againt folders plugin version 5.0
      Folders plugin 5.0 has as minimum version 1.609.1 of jenkins.
      I have a jenkins on 1.580.3 and folders plugin 4.10
      If I enable in a jobgroup "Jobs and Folders marked for inclusion", I get the following exception when configuring a job
      Caused by: java.lang.NoClassDefFoundError: com/cloudbees/hudson/plugins/folder/AbstractFolder
      So either the plugin is fixed so it can handle also older version of the folders plugin, or the minimum required version of Jenkins is set to 1.609.1

        Attachments

          Activity

          Hide
          oleg_nenashev Oleg Nenashev added a comment - - edited

          It was caused by JENKINS-37644.
          The plugin now explicitly requires Folders 5.0 or above

          Show
          oleg_nenashev Oleg Nenashev added a comment - - edited It was caused by JENKINS-37644 . The plugin now explicitly requires Folders 5.0 or above

            People

            Assignee:
            oleg_nenashev Oleg Nenashev
            Reporter:
            mawinter69 Markus Winter
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: