Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-40913

test run time totals for test suites in table is the run time for the first test suite

    XMLWordPrintable

Details

    Description

      st of all: really useful (and pretty ) plugin. Thanks @[LL LL|../....
      First of all: really useful (and pretty ) plugin. Thanks

      @[LL LL|../../../../../../../../../display/~ll], Hello, I would guess you are seeing the same bug as me - or a related bug.

      I see that there is something funny when showing test run times in table: 2 bugs I think.

      I have one test suite in each junit xml results file.

      I'm using latest Test Results Analyser Plugin 0.3.4.

      1.

      I see that in the first column (for latest test run) that the run time shown for each test file and test suite is the same for all.

      The run time shown for all looks like the time for the first test suite.

      The run time shown for all looks matches the sum of time for each test in first test result file + a little extra.

      2.

      After the first column the time shown for junit xml file looks correct (matches the sum of time for each test).

      But the time shown for each test suite is the same as the first test suite of that column (or build).

      Attachments

        Activity

          People

            menonvarun Varun Menon
            jamesco James Coleman
            Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated: