Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-41572

ERROR: Unexpected error in launching an agent. This is probably a bug in Jenkins

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Won't Fix
    • Component/s: windows-slaves-plugin
    • Labels:
      None
    • Environment:
      Windows 10 64bit
      Jenkins ver. 2.32.1
    • Similar Issues:

      Description

      ERROR: Unexpected error in launching an agent. This is probably a bug in Jenkins
      java.net.ConnectException: Connection timed out
      at java.net.PlainSocketImpl.socketConnect(Native Method)
      at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339)
      at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200)
      at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182)
      at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
      at java.net.Socket.connect(Socket.java:579)
      at java.net.Socket.connect(Socket.java:528)
      at java.net.Socket.<init>(Socket.java:425)
      at java.net.Socket.<init>(Socket.java:208)
      at hudson.os.windows.ManagedWindowsServiceLauncher.launch(ManagedWindowsServiceLauncher.java:356)
      at hudson.slaves.SlaveComputer$1.call(SlaveComputer.java:261)
      at jenkins.util.ContextResettingExecutorService$2.call(ContextResettingExecutorService.java:46)
      at java.util.concurrent.FutureTask.run(FutureTask.java:262)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      at java.lang.Thread.run(Thread.java:745)

      The connection works when the Windows Firewall is disabled. As soon as it's enabled, the connection doesn't work.

      Can you offer any information for Windows Firewall settings? Rules?

        Attachments

          Issue Links

            Activity

            Hide
            oleg_nenashev Oleg Nenashev added a comment -

            Please provide your Windows slave configuration. Likely your slave just cannot connect to the host/port

            Show
            oleg_nenashev Oleg Nenashev added a comment - Please provide your Windows slave configuration. Likely your slave just cannot connect to the host/port
            Hide
            oleg_nenashev Oleg Nenashev added a comment -

            I need a config.xml file for the slave you're trying to connect. Just as a first step of triangulation

            Show
            oleg_nenashev Oleg Nenashev added a comment - I need a config.xml file for the slave you're trying to connect. Just as a first step of triangulation
            Hide
            oleg_nenashev Oleg Nenashev added a comment -

            Config.xml for agents is commonly located in JENKINS_HOME/nodes/NODE_NAME

            Show
            oleg_nenashev Oleg Nenashev added a comment - Config.xml for agents is commonly located in JENKINS_HOME/nodes/NODE_NAME
            Hide
            oleg_nenashev Oleg Nenashev added a comment -

            JENKINS_HOME is on master

            Show
            oleg_nenashev Oleg Nenashev added a comment - JENKINS_HOME is on master
            Hide
            oleg_nenashev Oleg Nenashev added a comment -

            T. King It is a bugtracker, not a support site. There is no SLAs, several-day response delays are fine. It is a responsibility of reporters to provide a good issue description and to google a bit in order to find locations of config files, etc. The most of us contribute the project during their spare time, which is not something consistent. Please avoid such pinging.

            Just attach the file to the ticket. I have no idea what to look for since I do not know your slave configuration. Likely there is no bug in Jenkins at all, and you need to allow connection to the Jenkins JNLP port (in Global security settings).

            Show
            oleg_nenashev Oleg Nenashev added a comment - T. King It is a bugtracker, not a support site. There is no SLAs, several-day response delays are fine. It is a responsibility of reporters to provide a good issue description and to google a bit in order to find locations of config files, etc. The most of us contribute the project during their spare time, which is not something consistent. Please avoid such pinging. Just attach the file to the ticket. I have no idea what to look for since I do not know your slave configuration. Likely there is no bug in Jenkins at all, and you need to allow connection to the Jenkins JNLP port (in Global security settings).
            Hide
            kingtr_ngc T. King added a comment -

            No further comments. I'll seek support through other channels.

            Show
            kingtr_ngc T. King added a comment - No further comments. I'll seek support through other channels.

              People

              Assignee:
              oleg_nenashev Oleg Nenashev
              Reporter:
              kingtr_ngc T. King
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: