Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-41654

Please release a new version with virtualenv 15.1.0 bundled, to support Python 3.6

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Subject line says it all really, I hope this is quick and simple and can be done soon!

        Attachments

          Activity

          Hide
          ssbarnea Sorin Sbarnea added a comment -

          I would that this is an essential fix, not only for Python 3.6. For example due to the outdated virtualenv that is used by shiningpanda we are forced to introduce a pip and setuptools upgrade as part of each job because some python packages are failing to install with the ancient default pip/setuptools installed by default.

          Show
          ssbarnea Sorin Sbarnea added a comment - I would that this is an essential fix, not only for Python 3.6. For example due to the outdated virtualenv that is used by shiningpanda we are forced to introduce a pip and setuptools upgrade as part of each job because some python packages are failing to install with the ancient default pip/setuptools installed by default.
          Hide
          jameshowe James Howe added a comment -

          Ideally the builtin venv module should be used, rather than an external tool.

          Show
          jameshowe James Howe added a comment - Ideally the builtin venv module should be used, rather than an external tool.

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            cjw296 Chris Withers
            Votes:
            2 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated: