Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4204

CppUnit plugin crashes on empty result files

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Critical
    • Resolution: Duplicate
    • other
    • None
    • Platform: All, OS: All

    Description

      I sometimes (rather more frequently than desirable) have unittests that crash.
      These leave behind an empty .xml file (0 bytes), which causes the cppunit plugin
      to crash with the exception as attached (there's a "Premature End Of File" in it).
      When it does that, it also fails to keep the results of the other unittests (we
      run many unittest programs per build), so the trend and test overview are less
      usable than they could be.
      I think this is a regression from earlier versions. This is happening with
      v0.5.1, but v0.3 seemed to ignore empty files or at least handle them gracefully.

      Of course, this is a build error, and it's thus OK if CppUnit causes the build
      to fail because of this. It's also OK if it doesn't, because I catch the failure
      by other means also.

      Attachments

        Issue Links

          Activity

            torbent torbent added a comment -

            Created an attachment (id=868)
            Example XMl file, contains a 0x1a character

            torbent torbent added a comment - Created an attachment (id=868) Example XMl file, contains a 0x1a character
            torbent torbent added a comment -

            Closing this issue. I'll take further discussion of this problem in cppunit to
            issue 4305, and open a new issue about the problem in xUnit (yes, sorry).

            torbent torbent added a comment - Closing this issue. I'll take further discussion of this problem in cppunit to issue 4305, and open a new issue about the problem in xUnit (yes, sorry).

            Cppunit plugin will be no more enhanced after the resolution of this issue.
            Please, could you uninstall cppunit plugin and install xUnit plugin (with
            cppunit support).
            An empty result file is supported.

            gbois Gregory Boissinot added a comment - Cppunit plugin will be no more enhanced after the resolution of this issue. Please, could you uninstall cppunit plugin and install xUnit plugin (with cppunit support). An empty result file is supported.
            torbent torbent added a comment -

            More or the less the same as issue 4305. It's all to do with handling of
            non-compliant xml files.

                • This issue has been marked as a duplicate of 4305 ***
            torbent torbent added a comment - More or the less the same as issue 4305. It's all to do with handling of non-compliant xml files. This issue has been marked as a duplicate of 4305 ***
            torbent torbent added a comment -

            Created an attachment (id=836)
            Exception dump, taken from build output

            torbent torbent added a comment - Created an attachment (id=836) Exception dump, taken from build output

            People

              Unassigned Unassigned
              torbent torbent
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: