Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4206

AssertionError: "Releasing unallocated workspace"

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: All, OS: Linux
    • Similar Issues:

      Description

      FATAL: Releasing unallocated workspace /hudson/workspaces/TRUNK-PATCH
      java.lang.AssertionError: Releasing unallocated workspace
      /hudson/workspaces/TRUNK-PATCH
      at hudson.slaves.WorkspaceList.release(WorkspaceList.java:74)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:365)
      at hudson.model.Run.run(Run.java:1090)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:93)
      at hudson.model.Executor.run(Executor.java:122)

        Attachments

          Issue Links

            Activity

            kohsuke Kohsuke Kawaguchi added a comment -

            A report in the users list. He uses a custom workspace, too.
            ------------------
            I'm unable to comment on the issue for some reason. In any case here's
            some info:
            1. It is repeatable.
            2. The user is not letting Hudson use SCM. In the command area he's
            pulling things out of Perforce directly. Don't ask me why...
            3. No slaves.

            Here is the config. XXX's are masks.

            <?xml version='1.0' encoding='UTF-8'?>
            <project>
            <actions/>
            <description></description>
            <keepDependencies>false</keepDependencies>
            <properties/>
            <scm class="hudson.plugins.perforce.PerforceSCM">
            <p4User>chelck</p4User>
            <p4Passwd></p4Passwd>
            <p4Port>XXXXXXXXXXX:1666</p4Port>
            <p4Client>guest-hudson-ai-common</p4Client>
            <projectPath>//depot/Ati/common/main/...</projectPath>
            <p4Exe>/home/cc/bin/p4</p4Exe>
            <p4SysDrive></p4SysDrive>
            <p4SysRoot></p4SysRoot>
            <depot>
            <logger class="org.slf4j.impl.SimpleLogger">
            <name>perforce</name>
            </logger>
            <settings>
            <entry>
            <string>SystemRoot</string>
            <string></string>
            </entry>
            <entry>
            <string>P4PORT</string>
            <string>XXXXXXXXXXX:1666</string>
            </entry>
            <entry>
            <string>CLASSPATH</string>
            <string>/usr/share/java/p4.jar</string>
            </entry>
            <entry>
            <string>P4USER</string>
            <string>XXXXX</string>
            </entry>
            <entry>
            <string>P4PASSWD</string>
            <string>XXXXX</string>
            </entry>
            <entry>
            <string>P4CLIENT</string>
            <string>guest-hudson-ai-common</string>
            </entry>
            <entry>
            <string>SystemDrive</string>
            <string></string>
            </entry>
            <entry>
            <string>PATH</string>
            <string>/home/cc/bin</string>
            </entry>
            </settings>
            <pathSep>:</pathSep>
            <fileSep>/</fileSep>
            <validEnvp>false</validEnvp>
            <p4exe>/home/cc/bin/p4</p4exe>
            <threshold>10000</threshold>
            <execFactory
            class="com.tek42.p
            ce.process.DefaultExecutorFactory">
            <env>
            <entry>
            <string>P4PORT</string>
            <string>XXXXXXXXXXX:1666</string>
            </entry>
            <entry>
            <string>SystemRoot</string>
            <string></string>
            </entry>
            <entry>
            <string>P4USER</string>
            <string>XXXXXX</string>
            </entry>
            <entry>
            <string>CLASSPATH</string>
            <string>/usr/share/java/p4.jar</string>
            </entry>
            <entry>
            <string>P4PASSWD</string>
            <string>XXXXXXX</string>
            </entry>
            <entry>
            <string>P4CLIENT</string>
            <string>guest-hudson-ai-common</string>
            </entry>
            <entry>
            <string>SystemDrive</string>
            <string></string>
            </entry>
            <entry>
            <string>PATH</string>
            <string>/home/cc/bin</string>
            </entry>
            </env>
            </execFactory>
            <changes>
            <depot reference="../.."/>
            <logger class="org.slf4j.impl.SimpleLogger"
            reference="../../logger"/>
            </changes>
            <workspaces>
            <depot reference="../.."/>
            <logger class="org.slf4j.impl.SimpleLogger"
            reference="../../logger"/>
            </workspaces>
            <users>
            <depot reference="../.."/>
            <logger class="org.slf4j.impl.SimpleLogger"
            reference="../../logger"/>
            </users>
            </depot>
            <forceSync>false</forceSync>
            <updateView>false</updateView>
            <firstChange>-1</firstChange>
            </scm>
            <canRoam>true</canRoam>
            <disabled>false</disabled>
            <triggers class="vector">
            <hudson.triggers.TimerTrigger>
            <spec>0 0 * * *</spec>
            </hudson.triggers.TimerTrigger>
            </triggers>
            <concurrentBuild>false</concurrentBuild>
            <builders>
            <hudson.tasks.Shell>
            <command>export
            ANT_HOME=/export/home/cc/applications/buildtools/ant/apache-ant-1.6.2
            export PATH=${ANT_HOME}/bin:$PATH
            >
            </hudson.tasks.Shell>
            </builders>
            <publishers>
            <hudson.tasks.ArtifactArchiver>
            <artifacts>Ati/common/main/libs/common.jar</artifacts>
            <latestOnly>true</latestOnly>
            </hudson.tasks.ArtifactArchiver>
            <hudson.tasks.JavadocArchiver>
            <javadocDir>Ati/common/main/common_reports/javadoc</javadocDir>
            <keepAll>false</keepAll>
            </hudson.tasks.JavadocArchiver>
            <hudson.plugins.warnings.WarningsPublisher>
            <threshold></threshold>
            <healthy></healthy>
            <unHealthy></unHealthy>
            <height></height>
            <pluginName>[WARNINGS] </pluginName>
            <thresholdLimit>low</thresholdLimit>
            <parserNames/>
            <canRunOnFailed>false</canRunOnFailed>
            </hudson.plugins.warnings.WarningsPublisher>
            <hudson.tasks.Mailer>
            <recipients>Greg.Szumowski@us.icap.com</recipients>
            <dontNotifyEveryUnstableBuild>false</dontNotifyEveryUnstableBuild>
            <sendToIndividuals>true</sendToIndividuals>
            </hudson.tasks.Mailer>
            <hudson.tasks.BuildTrigger>
            <childProjects>ai_main_server, ai_server_5.0</childProjects>
            <threshold>
            <name>SUCCESS</name>
            <ordinal>0</ordinal>
            <color>BLUE</color>
            </threshold>
            </hudson.tasks.BuildTrigger>
            </publishers>
            <buildWrappers/>

            <customWorkspace>/home/cc/applications/hudson/jobs/ai_main_common/worksp
            ace/</customWorkspace>
            </project>

            mdonohue mdonohue added a comment -
                • Issue 4211 has been marked as a duplicate of this issue. ***
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : kohsuke
            Path:
            trunk/hudson/main/core/src/main/java/hudson/matrix/MatrixRun.java
            trunk/hudson/main/core/src/main/java/hudson/model/AbstractBuild.java
            trunk/hudson/main/core/src/main/java/hudson/model/AbstractProject.java
            trunk/hudson/main/core/src/main/java/hudson/model/FreeStyleBuild.java
            trunk/hudson/main/core/src/main/java/hudson/model/FreeStyleProject.java
            trunk/hudson/main/core/src/main/java/hudson/slaves/WorkspaceList.java
            trunk/hudson/main/maven-plugin/src/main/java/hudson/maven/MavenBuild.java
            trunk/hudson/main/test/src/test/java/hudson/model/FreeStyleProjectTest.java
            trunk/www/changelog.html
            http://fisheye4.cenqua.com/changelog/hudson/?cs=20632
            Log:
            [FIXED JENKINS-4206] in 1.320. Custom workspace and new workspace lease scheme had a bad interaction.

            torbent torbent added a comment -

            CC += me
            Looking forward to the release. Would have added that it happened for all our
            builds during the short period I ran 1.319, that all builds use custom
            workspace, and that we have one master and 3 slaves. We use Perforce as SCM.
            Some jobs are tied to slaves, none to master (but many default to it).
            But that's not important now

            torbent torbent added a comment -

            Hudson 1.321 works fine again for me. Issue can be closed?


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              sberlotto sberlotto
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: