Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-42067

Any commit to common library SCM repository triggers all pipeline build plans

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: pipeline
    • Labels:
      None
    • Similar Issues:

      Description

      I'm using Modern SCM repository to maintain common library functions referenced by component build plan Jenkinsfiles. Any commit to the common library code appears to trigger a re-build of all Pipeline build plans, without an option to disable this feature. I'd like to selectively re-build everything, instead of automatically triggering all builds (which will result in a lot of unnecessary builds in my case). I've tried changing the implicit loading behaviour of the library, and also the option to "Ignore on push notifications" when defining the common library in system configuration options.

      Is there a way to disable auto-triggering the Pipeline build plans when committing changes to the common library repository?

        Attachments

          Issue Links

            Activity

            bparker Brandon Parker added a comment -

            This is a major issue as there is no reason for this to be the default behavior. It is certainly not something that I would have expected.
            This also happens when using a repo as the source of a Jenkinsfile, all jobs using that repo get built. In our workflow that causes the builds to fail because there are no changes to build.

            bpfh Sami Lempinen added a comment -

            I agree, this is causing major headache at one of our clients at the moment. Setting Ignore on push notifications makes no difference, and I've experimented with Don't trigger a build on commit notifications in Configure System, to no avail. As a result, we are now limited to making changes to the global pipeline library outside business hours, as it tends to flood our build farm.

            We are using Bitbucket Server, and for the Jenkins hook to work, jobs need to have Poll SCM enabled.  

            duemir Denys Digtiar added a comment -

            Looks like a duplicate of JENKINS-41497


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              aceponkus Andrew Ceponkus
              Votes:
              11 Vote for this issue
              Watchers:
              14 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: