Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4212

Edit View link incorrect in customized Default View setup

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • core
    • None
    • Platform: All, OS: All

    Description

      If you've specified a custom Default View (one other than All), the Edit View
      link will be incorrect.

      Whereas most Edit View links go to "hudson/view/MyView/configure", the Edit
      View on the Default View goes to "hudson/configure" instead.

      Attachments

        Issue Links

          Activity

            mindless Alan Harder added a comment -
                • Issue 4213 has been marked as a duplicate of this issue. ***
            mindless Alan Harder added a comment - Issue 4213 has been marked as a duplicate of this issue. ***
            mindless Alan Harder added a comment -

            started

            mindless Alan Harder added a comment - started

            Code changed in hudson
            User: : mindless
            Path:
            trunk/hudson/main/core/src/main/java/hudson/model/View.java
            trunk/hudson/main/core/src/main/resources/hudson/model/View/sidepanel.jelly
            http://fisheye4.cenqua.com/changelog/hudson/?cs=20764
            Log:
            [FIXED JENKINS-4212] Use view/

            {name}

            in Edit View and New Job links even on page for
            the default view, so when the default is not "All" these links work on the right view.

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : mindless Path: trunk/hudson/main/core/src/main/java/hudson/model/View.java trunk/hudson/main/core/src/main/resources/hudson/model/View/sidepanel.jelly http://fisheye4.cenqua.com/changelog/hudson/?cs=20764 Log: [FIXED JENKINS-4212] Use view/ {name} in Edit View and New Job links even on page for the default view, so when the default is not "All" these links work on the right view.

            People

              mindless Alan Harder
              rtyler R. Tyler Croy
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: