Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-42197

Job import plugin refreshes the page after clicking on "Query" button

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: In Review (View Workflow)
    • Priority: Blocker
    • Resolution: Cannot Reproduce
    • Component/s: job-import-plugin
    • Labels:
      None
    • Environment:
      Jenkins ver. 2.7.20.2 (CloudBees Jenkins Enterprise 2.7.20.2-rolling)
      Job import plugin - 1.6
    • Similar Issues:

      Description

      1) Navigate to /job-import/ page
      2) Provided Remote Jenkins URL:
      3) Added credentials - Credentials
      4) Click on "Query"

      Observation/Issue - Page refreshes and nothing happens (No stack trace)

      I am seeing js error in my browser console - Use of getAttributeNode() is deprecated. Use getAttribute() instead.

        Attachments

          Activity

          vmarin Valentin Marin added a comment -

          If that is indeed the case, then it is still a regression, because previously it only took about a minute to execute the query and list the jobs from another server in our business unit.

          However, it does not seem to work for me even after waiting for half-an-hour and refreshing the page. We're also talking about different jenkins core and plug-in versions here, as job-import 1.6 does not work on any of our servers. We had to roll back to whatever previous version was available for each server and still it does nothing.

          manideepl manideepl lanka added a comment - - edited

          I too face the issue.

          Trying to import from Jenkins 1.642.3 to Jenkins 2.73.3 using plugin 2.1.

           

          And waiting for some time and refreshing does not help

          sekharraja455 raja sekhar added a comment - - edited

          i too face same issue with from Jenkins 2.46.2 to Jenkins 2.46.2 using import plugin 2.1

          waited long time and refreshed but doesn't help .

          please do help on this.

          jwalsh2nu John Walsh added a comment -

          Same issue...

          oifergan80 omri ifergan added a comment - - edited

          on my station:

           

          jenkins 2.121.2

          plugin ver 3.0

           

          i get the following page without possibility to add remote server:

           

           


            People

            Assignee:
            escoem Emilio Escobar
            Reporter:
            darshan Darshan Deshmukh
            Votes:
            1 Vote for this issue
            Watchers:
            6 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: