Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4255

Delete update problems on next try

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Every update attempt during one session is recorded in the error log. When you
      try another update its messages are put below the old ones.

      When I try a lot of updates that I have to scroll down to the end every time. I
      also get confused when I see an error message right after clicking update. Then
      I realize that I have to scroll down

      Is this really necessary or can you maybe delete the error messages when someone
      starts the next update?

        Attachments

          Activity

          mindless Alan Harder added a comment -

          Easy steps to reproduce:

          1. visit Plugin Manager / Advanced and put invalid proxy settings in place
          2. try an update.. it will fail due to invalid proxy
          3. return to Advanced tab and correct proxy settings
          4. do a new update.. although this succeeds, the big error from the earlier attempt dominates the display.
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : mindless
          Path:
          trunk/hudson/main/core/src/main/resources/hudson/model/UpdateCenter/ConnectionCheckJob/row.jelly
          trunk/hudson/main/core/src/main/resources/hudson/model/UpdateCenter/DownloadJob/Failure/status.jelly
          trunk/hudson/main/core/src/main/resources/hudson/model/UpdateCenter/DownloadJob/row.jelly
          trunk/hudson/main/core/src/main/resources/hudson/model/UpdateCenter/index.jelly
          trunk/www/changelog.html
          http://jenkins-ci.org/commit/30680
          Log:
          [FIXED JENKINS-4255] hide exception traces on Update Center page by default
          (with "Details" link to see them), to keep this page shorter and make it easier
          to find the latest update jobs when retrying after failure. Also scroll to
          bottom of page when it first loads, for the same reason.


            People

            Assignee:
            mindless Alan Harder
            Reporter:
            flominator Flominator
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: