Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-42642

Warnings reported intermittently

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Minor
    • Resolution: Fixed
    • warnings-plugin
    • None
    • Jenkins 2.32.3, warnings plugin 4.60

    Description

      I have a pipeline job where the warnings are displayed only sometimes. When building a new commit, they are there. Rebuilding that commit shows the warnings, until it doesn't anymore. Rebuilding after that doesn't bring them back in the report (of course they are present in the log). If it should matter, it is with the Erlang parser.

      Attachments

        Issue Links

          Activity

            vladdu Vlad Dumitrescu added a comment - - edited

            Oops, exactly when I said that I got a "no warnings" run... So a three seconds delay doesn't help.

            vladdu Vlad Dumitrescu added a comment - - edited Oops, exactly when I said that I got a "no warnings" run... So a three seconds delay doesn't help.
            drulli Ulli Hafner added a comment - - edited

            Are the messages the same for the working builds? The warnings plugin should report a line that shows the actual number of warnings...

            drulli Ulli Hafner added a comment - - edited Are the messages the same for the working builds? The warnings plugin should report a line that shows the actual number of warnings...

            The logs are exactly the same. No summary (and I can't see one in other jobs either).

            vladdu Vlad Dumitrescu added a comment - The logs are exactly the same. No summary (and I can't see one in other jobs either).

            I think there was an issue on my side, it works now with the `sleep` workaround, so it is a duplicate of  JENKINS-32191. Thanks!

            vladdu Vlad Dumitrescu added a comment - I think there was an issue on my side, it works now with the `sleep` workaround, so it is a duplicate of  JENKINS-32191 . Thanks!
            drulli Ulli Hafner added a comment -

            Ok, then please vote for the other issue to get it fixed as soon as possible

            drulli Ulli Hafner added a comment - Ok, then please vote for the other issue to get it fixed as soon as possible

            People

              drulli Ulli Hafner
              vladdu Vlad Dumitrescu
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: