Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-43352

Upgrade Delivery Pipeline plugin Java and core requirements

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Delivery Pipeline Plugin currently supports Java 6 and Jenkins 1.565. In order to prepare for new features and support of newer plugins we need to update our minimum supported Jenkins core version. We can now also require the plugin to be run on Java 7 since Java 6 reached the end of its supported life in 2013.

      • Raise Java requirement to Java 7
      • Update core dependency to 1.642.3

        Attachments

          Activity

          Hide
          tommysdk Tommy Tynjä added a comment -

          Pull request merged: https://github.com/Diabol/delivery-pipeline-plugin/pull/234

          Released in 1.0.0

          Show
          tommysdk Tommy Tynjä added a comment - Pull request merged: https://github.com/Diabol/delivery-pipeline-plugin/pull/234 Released in 1.0.0

            People

            Assignee:
            tommysdk Tommy Tynjä
            Reporter:
            tommysdk Tommy Tynjä
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: