Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-43690

Copy artifact plugin reports 'Failed to set the timestamp...'

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Component/s: copyartifact-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.55
      Copy artifact plugin 1.38.1
    • Similar Issues:

      Description

      Our system log shows multiple errors similar to:

      Apr 19, 2017 12:01:38 PM WARNING hudson.plugins.copyartifact.FingerprintingCopyMethod copyOne
      remote file operation failed: /net/<snip>/html/Gain{complex{double}}.html at hudson.remoting.Channel@3c6a155b:hwsim37: java.io.IOException: Failed to set the timestamp of <snip>/html/Gain{complex{double}}.html to 1492599498000

        Attachments

          Activity

          davida2009 David Aldrich created issue -
          ikedam ikedam added a comment -

          Would you describe which the your point is?

          • Copyartifact should not report warnings even if it fails to set timestamp.
          • Copyartifact reports error even though it should succeeds to set timestamp.
            • In this case, please report followings
              • The executing user id of the Java process of Jenkins.
              • Owners and permissions of following files:
                • <snip>/html
                • <snip>/html/Gain{complex{double}}.html
              • OS
              • Filesystem (ext4 or something like that)
          ikedam ikedam made changes -
          Field Original Value New Value
          Assignee David Aldrich [ davida2009 ]
          davida2009 David Aldrich made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Open [ 1 ] Resolved [ 5 ]
          davida2009 David Aldrich made changes -
          Status Resolved [ 5 ] Closed [ 6 ]

            People

            Assignee:
            davida2009 David Aldrich
            Reporter:
            davida2009 David Aldrich
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: