Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-43932

ERROR message at the end of every build from splunk plugin

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Won't Fix
    • Component/s: splunk-devops-plugin
    • Labels:
      None
    • Environment:
      Splunk Plugin 1.4.2
      Jenkins ver. 1.651.22.1 (CloudBees Jenkins Enterprise 16.06)
    • Similar Issues:

      Description

      We find the error below at the end of every jenkins build after we install a JIRA plugin

      "ERROR: Unable to notify HSBC JIRA: [403] Forbidden"

      JIRA plugin:
      https://marketplace.atlassian.com/plugins/com.marvelution.jira.plugins.jenkins/server/overview

      From the jenkins.log file, it shows the error is from the splunk plugin. Splunk plugin version we are using is 1.4.2. Please help to check and advise how to fix this.

      Apr 27, 2017 6:21:06 PM com.splunk.splunkjenkins.utils.LogConsumer run
      SEVERE: message not delivered:

      {length:151 2017-04-27T18:21:06.234+0100 line:1297 ERROR: Unable to notify HSBC JIRA: [403] Forbidden 2017-04-27T18:21:06.238+0100 line:1298 Finished: SUCCESS ...}

      com.splunk.splunkjenkins.utils.LogConsumer$SplunkClientError: Not Found, status code:404
      at com.splunk.splunkjenkins.utils.LogConsumer$1.handleResponse(LogConsumer.java:68)
      at com.splunk.splunkjenkins.utils.LogConsumer$1.handleResponse(LogConsumer.java:40)
      at shaded.splk.org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:222)
      at shaded.splk.org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:164)
      at shaded.splk.org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:139)
      at com.splunk.splunkjenkins.utils.LogConsumer.run(LogConsumer.java:89)

        Attachments

          Activity

          fengxx Ted Xiao added a comment - - edited

          There are two issues
          1. splunk configure issues

          com.splunk.splunkjenkins.utils.LogConsumer$SplunkClientError: Not Found, status code:404
          It seems your splunk server configuration is not correct, please goto global configure page and test the connection.
          
          

          2. jira plugin configure issue

          2017-04-27T18:21:06.234+0100 line:1297 ERROR: Unable to notify HSBC JIRA: [403] Forbidden
          

          This error is showed in your build log (check your job/buildnumber/console), and splunk plugin tried to send the console log but also failed (see item1), but the error message is not caused by splunk plugin. I can not help on this issue.


            People

            Assignee:
            fengxx Ted Xiao
            Reporter:
            lyc1986830 yc li
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: