Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-441

Executed Mojos page throws jelly parse exception

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      The new executed mojos page throws an exception indicating a problem with a
      jelly script. The stacktrace below is from Tomcat 6.0.10, hudson 1.98.

      This exception happens for me every time I click the "Executed Mojos" link from
      any m2 build.

      javax.servlet.ServletException: org.apache.commons.jelly.JellyException: Could
      not parse Jelly script
      org.kohsuke.stapler.MetaClass$3.dispatch(MetaClass.java:119)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
      org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:361)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
      org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:361)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
      org.kohsuke.stapler.MetaClass$9.doDispatch(MetaClass.java:240)
      org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:207)
      org.kohsuke.stapler.Stapler.service(Stapler.java:72)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:803)

      root cause

      org.apache.commons.jelly.JellyException: Could not parse Jelly script
      org.apache.commons.jelly.JellyContext.compileScript(JellyContext.java:525)
      org.kohsuke.stapler.jelly.JellyClassTearOff.parseScript(JellyClassTearOff.java:35)
      org.kohsuke.stapler.jelly.JellyClassTearOff.parseScript(JellyClassTearOff.java:28)
      org.kohsuke.stapler.AbstractTearOff.findScript(AbstractTearOff.java:53)
      org.kohsuke.stapler.MetaClass$3.dispatch(MetaClass.java:102)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
      org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:361)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
      org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:361)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
      org.kohsuke.stapler.MetaClass$9.doDispatch(MetaClass.java:240)
      org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:207)
      org.kohsuke.stapler.Stapler.service(Stapler.java:72)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:803)

      root cause

      org.apache.commons.jelly.util.SAXParseException: Error at (8, 50) of
      jar:file:/opt/tomcat-hudson/webapps/hudson/WEB-INF/lib/hudson-core-1.98.jar!/hudson/maven/MavenBuild/executedMojos.jelly
      : Unable to create expression: empty(it.executedMojos
      org.apache.commons.jelly.parser.XMLParser.createSAXException(XMLParser.java:1185)
      org.apache.commons.jelly.parser.XMLParser.createSAXException(XMLParser.java:1207)
      org.apache.commons.jelly.parser.XMLParser.createTag(XMLParser.java:1036)
      org.apache.commons.jelly.parser.XMLParser.startElement(XMLParser.java:593)
      com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.startElement(AbstractSAXParser.java:533)
      com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.scanStartElement(XMLNSDocumentScannerImpl.java:330)
      com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(XMLDocumentFragmentScannerImpl.java:1693)
      com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:368)
      com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:834)
      com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:764)
      com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:148)
      com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1168)
      org.apache.commons.jelly.parser.XMLParser.parse(XMLParser.java:312)
      org.apache.commons.jelly.JellyContext.compileScript(JellyContext.java:521)
      org.kohsuke.stapler.jelly.JellyClassTearOff.parseScript(JellyClassTearOff.java:35)
      org.kohsuke.stapler.jelly.JellyClassTearOff.parseScript(JellyClassTearOff.java:28)
      org.kohsuke.stapler.AbstractTearOff.findScript(AbstractTearOff.java:53)
      org.kohsuke.stapler.MetaClass$3.dispatch(MetaClass.java:102)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
      org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:361)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
      org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:361)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
      org.kohsuke.stapler.MetaClass$9.doDispatch(MetaClass.java:240)
      org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:207)
      org.kohsuke.stapler.Stapler.service(Stapler.java:72)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:803)

      root cause

      org.apache.commons.jelly.JellyException: Unable to create expression:
      empty(it.executedMojos
      org.apache.commons.jelly.expression.jexl.JexlExpressionFactory.createExpression(JexlExpressionFactory.java:64)
      org.apache.commons.jelly.expression.CompositeExpression.parse(CompositeExpression.java:82)
      org.apache.commons.jelly.TagLibrary.createExpression(TagLibrary.java:120)
      org.apache.commons.jelly.parser.XMLParser.createTag(XMLParser.java:1016)
      org.apache.commons.jelly.parser.XMLParser.startElement(XMLParser.java:593)
      com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.startElement(AbstractSAXParser.java:533)
      com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.scanStartElement(XMLNSDocumentScannerImpl.java:330)
      com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(XMLDocumentFragmentScannerImpl.java:1693)
      com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:368)
      com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:834)
      com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:764)
      com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:148)
      com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1168)
      org.apache.commons.jelly.parser.XMLParser.parse(XMLParser.java:312)
      org.apache.commons.jelly.JellyContext.compileScript(JellyContext.java:521)
      org.kohsuke.stapler.jelly.JellyClassTearOff.parseScript(JellyClassTearOff.java:35)
      org.kohsuke.stapler.jelly.JellyClassTearOff.parseScript(JellyClassTearOff.java:28)
      org.kohsuke.stapler.AbstractTearOff.findScript(AbstractTearOff.java:53)
      org.kohsuke.stapler.MetaClass$3.dispatch(MetaClass.java:102)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
      org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:361)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
      org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:361)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
      org.kohsuke.stapler.MetaClass$9.doDispatch(MetaClass.java:240)
      org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:207)
      org.kohsuke.stapler.Stapler.service(Stapler.java:72)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:803)

      root cause

      org.apache.commons.jexl.parser.ParseException: Encountered ";" at line 1, column 23.
      Was expecting one of:
      ")" ...
      "[" ...
      "(" ...
      "." ...

      org.apache.commons.jexl.parser.Parser.generateParseException(Parser.java:4176)
      org.apache.commons.jexl.parser.Parser.jj_consume_token(Parser.java:4043)
      org.apache.commons.jexl.parser.Parser.EmptyFunction(Parser.java:194)
      org.apache.commons.jexl.parser.Parser.PrimaryExpression(Parser.java:1686)
      org.apache.commons.jexl.parser.Parser.UnaryExpression(Parser.java:1658)
      org.apache.commons.jexl.parser.Parser.MultiplicativeExpression(Parser.java:1299)
      org.apache.commons.jexl.parser.Parser.AdditiveExpression(Parser.java:1206)
      org.apache.commons.jexl.parser.Parser.RelationalExpression(Parser.java:891)
      org.apache.commons.jexl.parser.Parser.EqualityExpression(Parser.java:724)
      org.apache.commons.jexl.parser.Parser.AndExpression(Parser.java:676)
      org.apache.commons.jexl.parser.Parser.ExclusiveOrExpression(Parser.java:628)
      org.apache.commons.jexl.parser.Parser.InclusiveOrExpression(Parser.java:580)
      org.apache.commons.jexl.parser.Parser.ConditionalAndExpression(Parser.java:487)
      org.apache.commons.jexl.parser.Parser.ConditionalOrExpression(Parser.java:394)
      org.apache.commons.jexl.parser.Parser.Expression(Parser.java:316)
      org.apache.commons.jexl.parser.Parser.ExpressionExpression(Parser.java:1884)
      org.apache.commons.jexl.parser.Parser.Statement(Parser.java:1858)
      org.apache.commons.jexl.parser.Parser.JexlScript(Parser.java:73)
      org.apache.commons.jexl.parser.Parser.parse(Parser.java:32)
      org.apache.commons.jexl.ExpressionFactory.createNewExpression(ExpressionFactory.java:122)
      org.apache.commons.jexl.ExpressionFactory.createExpression(ExpressionFactory.java:100)
      org.apache.commons.jelly.expression.jexl.JexlExpressionFactory.createExpression(JexlExpressionFactory.java:60)
      org.apache.commons.jelly.expression.CompositeExpression.parse(CompositeExpression.java:82)
      org.apache.commons.jelly.TagLibrary.createExpression(TagLibrary.java:120)
      org.apache.commons.jelly.parser.XMLParser.createTag(XMLParser.java:1016)
      org.apache.commons.jelly.parser.XMLParser.startElement(XMLParser.java:593)
      com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.startElement(AbstractSAXParser.java:533)
      com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.scanStartElement(XMLNSDocumentScannerImpl.java:330)
      com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(XMLDocumentFragmentScannerImpl.java:1693)
      com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:368)
      com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:834)
      com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:764)
      com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:148)
      com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1168)
      org.apache.commons.jelly.parser.XMLParser.parse(XMLParser.java:312)
      org.apache.commons.jelly.JellyContext.compileScript(JellyContext.java:521)
      org.kohsuke.stapler.jelly.JellyClassTearOff.parseScript(JellyClassTearOff.java:35)
      org.kohsuke.stapler.jelly.JellyClassTearOff.parseScript(JellyClassTearOff.java:28)
      org.kohsuke.stapler.AbstractTearOff.findScript(AbstractTearOff.java:53)
      org.kohsuke.stapler.MetaClass$3.dispatch(MetaClass.java:102)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
      org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:361)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
      org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:361)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
      org.kohsuke.stapler.MetaClass$9.doDispatch(MetaClass.java:240)
      org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:207)
      org.kohsuke.stapler.Stapler.service(Stapler.java:72)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:803)

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          Doh!

          Fixed in 1.99.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            rsutphin rsutphin
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: