Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-44150

Pipeline job not waiting for all triggered parallel jobs

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      When running this job with parallel enabled the parallel jobs terminate early causing failures.

      Files that were available at the beginning of parallel jobs are removed and errors such as:

      ```

      [4.8.1] /usr/local/bin/ruby: No such file or directory – extconf.rb (LoadError)
      [4.8.1] Gem files will remain installed in /usr/local/bundle/gems/json-1.8.6 for
      [4.8.1] Errno::ENOENT: No such file or directory @ chmod_internal

      ```

      When the parallel function is disabled the job runs without an issue but obviously takes longer since it can't take advantage of the parallel processing.

       

      Attached is the 2 jobs referencing the same shared library but with different tag references for the paralleldisabled and "enabled" versions for the required methods used by this job.

       

      As long as kubernetes-plugin is installed and configured this job should be able to run anywhere with an internet connection to retrieve the shared library and download the required images.

       

      Might be related to #44152

        Attachments

        1. paralleldisabled_console.txt
          93 kB
          Chris Denneen
        2. paralleldisabled.groovy
          0.7 kB
          Chris Denneen
        3. paralleltest_console.txt
          53 kB
          Chris Denneen
        4. paralleltest.groovy
          0.7 kB
          Chris Denneen

          Issue Links

            Activity

            Hide
            csanchez Carlos Sanchez added a comment -

            can you try the latest version?

            Show
            csanchez Carlos Sanchez added a comment - can you try the latest version?
            Hide
            vlatombe Vincent Latombe added a comment -

            Needs a full reproducer. In the logs, I see only one kubernetes node, so are you running parallel within that single node? I don't see anything specific to the kubernetes plugin, the problem would be the same within a static node.

            Show
            vlatombe Vincent Latombe added a comment - Needs a full reproducer. In the logs, I see only one kubernetes node, so are you running parallel within that single node? I don't see anything specific to the kubernetes plugin, the problem would be the same within a static node.

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              cdenneen Chris Denneen
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: