Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4443

Load rules containing spaces not handled properly

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • clearcase-plugin
    • None
    • Platform: All, OS: All

    Description

      See list thread for report - valid load rules containing spaces, such as
      "foo/bar baz/some_file", are not being handled properly. They're being passed to
      cleartool unquoted, resulting in errors like those reported in the email thread.

      Attachments

        Issue Links

          Activity

            abayer Andrew Bayer created issue -

            Code changed in hudson
            User: : abayer
            Path:
            trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/ClearToolExec.java
            trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/ClearToolSnapshot.java
            trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/AbstractClearCaseScmTest.java
            trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/ClearToolExecTest.java
            trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/ClearToolSnapshotTest.java
            http://fisheye4.cenqua.com/changelog/hudson/?cs=21609
            Log:
            [FIXED JENKINS-4443] Added checks in lshistory and update calls to quote load rules with spaces in them when encountered. Also added multiple tests for this as well.

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : abayer Path: trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/ClearToolExec.java trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/ClearToolSnapshot.java trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/AbstractClearCaseScmTest.java trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/ClearToolExecTest.java trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/ClearToolSnapshotTest.java http://fisheye4.cenqua.com/changelog/hudson/?cs=21609 Log: [FIXED JENKINS-4443] Added checks in lshistory and update calls to quote load rules with spaces in them when encountered. Also added multiple tests for this as well.
            scm_issue_link SCM/JIRA link daemon made changes -
            Field Original Value New Value
            Resolution Fixed [ 1 ]
            Status Open [ 1 ] Resolved [ 5 ]
            abayer Andrew Bayer added a comment -
                • Issue 4450 has been marked as a duplicate of this issue. ***
            abayer Andrew Bayer added a comment - Issue 4450 has been marked as a duplicate of this issue. ***
            abayer Andrew Bayer made changes -
            Link This issue is duplicated by JENKINS-4450 [ JENKINS-4450 ]
            abjoshi abjoshi added a comment -

            Hi,

            It seems that issue with space characters in the load paths have reappeared on the new plugin version. I have older version of the plugin (0.9.1) running on one hudson and latest version 1.2 on other hudson.

            The older one specifies load path as

            load "/XYZ/ABC File Management.sln"

            and newer one specifies the same but in seperate load path section now

            /XYZ/ABC Management.sln

            The old job succeeds to load the file while the newer one fails saying cleartool: Error: Unable to lookup "ABC" in "\XYZ@@\main\100": No such file or directory.
            cleartool: Error: Unable to access "\XYZ\ABC": No such file or directory.
            cleartool: Error: Pathname "File" is not a full VOB pathname: it does not begin with a "\".
            cleartool: Error: Pathname "Management.sln" is not a full VOB pathname: it does not begin with a "\".

            cleartool: Error: 3 config spec load rule problems encountered.
            Can you please check if the following fix with plug-in version 1.1 is really fixed?

            Bug fix: Load rules containing spaces are now handled properly in cleartool calls. (issue #4443)

            Regards,

            abhijit

            abjoshi abjoshi added a comment - Hi, It seems that issue with space characters in the load paths have reappeared on the new plugin version. I have older version of the plugin (0.9.1) running on one hudson and latest version 1.2 on other hudson. The older one specifies load path as load "/XYZ/ABC File Management.sln" and newer one specifies the same but in seperate load path section now /XYZ/ABC Management.sln The old job succeeds to load the file while the newer one fails saying cleartool: Error: Unable to lookup "ABC" in "\XYZ@@\main\100": No such file or directory. cleartool: Error: Unable to access "\XYZ\ABC": No such file or directory. cleartool: Error: Pathname "File" is not a full VOB pathname: it does not begin with a "\". cleartool: Error: Pathname "Management.sln" is not a full VOB pathname: it does not begin with a "\". cleartool: Error: 3 config spec load rule problems encountered. Can you please check if the following fix with plug-in version 1.1 is really fixed? Bug fix: Load rules containing spaces are now handled properly in cleartool calls. (issue #4443) Regards, abhijit
            abjoshi abjoshi made changes -
            Assignee abayer [ abayer ]
            Resolution Fixed [ 1 ]
            Status Resolved [ 5 ] Reopened [ 4 ]
            vlatombe Vincent Latombe made changes -
            Assignee vlatombe [ vlatombe ]

            Fixed in trunk

            vlatombe Vincent Latombe added a comment - Fixed in trunk
            vlatombe Vincent Latombe made changes -
            Resolution Fixed [ 1 ]
            Status Reopened [ 4 ] Resolved [ 5 ]

            Available since 1.3

            vlatombe Vincent Latombe added a comment - Available since 1.3
            vlatombe Vincent Latombe made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 134516 ] JNJira + In-Review [ 202896 ]

            People

              vlatombe Vincent Latombe
              abayer Andrew Bayer
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: