Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4450

Load rule paths containing whitespaces not handled properly?

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Critical
    • Resolution: Duplicate
    • clearcase-plugin
    • None
    • Platform: All, OS: All

    Description

      I use 1.01 of the plugin.

      I try to specify a load rule containing a folder with whitespaces in the name, like:

      Service\SE\InstallShield\Projects\Product Module Feature

      But the plugin seems to split the path at the whitespaces and interprets the
      tokens as new load rules or does not properly wrap the path in quotations.
      I get errors like:

      cleartool: Error: Unable to access "\Service\SE\InstallShield\Projects\Product":
      No such file or directory.
      cleartool: Error: Pathname "Module" is not a full VOB pathname: it does not
      begin with a "\".
      cleartool: Error: Pathname "Feature" is not a full VOB pathname: it does not
      begin with a "\".

      Using single and double quotation marks does not help.

      When trying:
      "Service\SE\InstallShield\Projects\Product Module Feature"
      as load rule I get:

      cleartool: Error: Unable to access
      "\"Service\SE\InstallShield\Projects\Product": No such file or directory.

      Attachments

        Issue Links

          Activity

            atticus atticus added a comment -

            Please disregard, duplicate of 4443

            atticus atticus added a comment - Please disregard, duplicate of 4443
            abayer Andrew Bayer added a comment -

            Duplicate

                • This issue has been marked as a duplicate of 4443 ***
            abayer Andrew Bayer added a comment - Duplicate This issue has been marked as a duplicate of 4443 ***

            People

              abayer Andrew Bayer
              atticus atticus
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: