Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-44697

Blueocean activity view for job has wrong status for pipeline with lots of stages

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Cannot Reproduce
    • blueocean-plugin
    • Blue Ocean 1.1, Blue Ocean 1.2-beta1, Blue Ocean 1.2-beta2, Blue Ocean 1.2-beta3, Blue Ocean 1.2-beta4, Blue Ocean 1.2, Blue Ocean 1.3, Blue Ocean 1.4 - beta 1, Blue Ocean 1.4 - beta 3, Blue Ocean 1.4 - beta 2, Blue Ocean 1.5 - beta 3

    Description

      If a Jenkins job named testjob1 that has a pipeline like this:

       

      pipeline {
          agent any;
          
          stages {
              stage("Stage 1") {
                  steps {
                      sh "sleep 20"               
                  }
                  
              }
              stage("Stage 2") {
                  steps {
                      sh "sleep 20"                
                  }
                  
              }
              stage("Stage 3") {
                  steps {
                      sh "sleep 20"                
                  }
                  
              }
              stage("Stage 4") {
                  steps {
                      sh "sleep 20"                
                  }
                  
              }
              stage("Stage 5") {
                  steps {
                      sh "sleep 20"                
                  }
                  
              }
              stage("Stage 6") {
                  steps {
                      sh "sleep 20"                
                  }
                  
              }
              stage("Stage 7") {
                  steps {
                      sh "sleep 20"                
                  }
                  
              }
              stage("Stage 8") {
                  steps {
                      sh "sleep 20"                
                  }
                  
              }
              stage("Stage 9") {
                  steps {
                      sh "sleep 20"                
                  }
                  
              }
              stage("Stage 10") {
                   steps {
                      sh "sleep 20"                
                  }
                 
              }
          }
      }

       

      If I go to https://myhost/blue/organizations/jenkins/testjob1/activity/

      After about 4 or 5 stages have completed, the status of the job shows as completed and succeeded, even though the job is still running.

       

      Attachments

        Activity

          jamesdumay James Dumay added a comment -

          rodrigc there is a big change coming in JENKINS-44981 and JENKINS-44981 which will change the way that we calculate the status of the pipeline. Ive been unable to reproduce this issue locally (I've tried a fair amount of things) but when the beta for these changes land, it would be great if you were able to give them a go

          Ill keep you posted.

          jamesdumay James Dumay added a comment - rodrigc there is a big change coming in JENKINS-44981 and JENKINS-44981 which will change the way that we calculate the status of the pipeline. Ive been unable to reproduce this issue locally (I've tried a fair amount of things) but when the beta for these changes land, it would be great if you were able to give them a go Ill keep you posted.
          jamesdumay James Dumay added a comment -

          I suspect this is related to what you are working on. We can run through the reproduction example when your work on statuses is looking more mature

          jamesdumay James Dumay added a comment - I suspect this is related to what you are working on. We can run through the reproduction example when your work on statuses is looking more mature
          michaelneale Michael Neale added a comment -

          Paused pending work on statuses 

          michaelneale Michael Neale added a comment - Paused pending work on statuses 
          kshultz Karl Shultz added a comment -

          Testing Notes:

          • On the UI side, the addition of an end-to-end Pipeline test with predictable results would be useful for testing this. Similar idea to what I've described in JENKINS-39203.
          • On the pipeline side, reading of various PRs, such as the ones for JENKINS-44981 reveals quite a lot of additional test coverage already.
          kshultz Karl Shultz added a comment - Testing Notes : On the UI side, the addition of an end-to-end Pipeline test with predictable results would be useful for testing this. Similar idea to what I've described in JENKINS-39203 . On the pipeline side, reading of various PRs, such as the ones for JENKINS-44981 reveals quite a lot of additional test coverage already.
          nicu Nicolae Pascu added a comment -

          I looked into this and could not replicate the problem, I talked with Josh and we decided to close the issue. We can re-open it in the future if someone will encounter this problem again.

          nicu Nicolae Pascu added a comment - I looked into this and could not replicate the problem, I talked with Josh and we decided to close the issue. We can re-open it in the future if someone will encounter this problem again.

          People

            nicu Nicolae Pascu
            rodrigc Craig Rodrigues
            Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: