Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-447

NotSerializableException on slave

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: remoting
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      On version 1.98 have got following error then build on slave:

      FATAL: remote file operation failed
      hudson.util.IOException2: remote file operation failed
      at hudson.FilePath.act(FilePath.java:230)
      at
      hudson.scm.SubversionChangeLogBuilder.getUrlForPath(SubversionChangeLogBuilder.java:85)
      at hudson.scm.SubversionChangeLogBuilder.run(SubversionChangeLogBuilder.java:72)
      at hudson.scm.SubversionSCM.calcChangeLog(SubversionSCM.java:176)
      at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:263)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:286)
      at hudson.model.AbstractBuild$AbstractRunner.checkout(AbstractBuild.java:150)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:116)
      at hudson.model.Run.run(Run.java:544)
      at hudson.model.Build.run(Build.java:99)
      at hudson.model.Executor.run(Executor.java:61)
      Caused by: java.io.IOException: Unable to serialize
      hudson.FilePath$FileCallableWrapper@8dd82b
      at hudson.remoting.UserRequest.serialize(UserRequest.java:91)
      at hudson.remoting.UserRequest.<init>(UserRequest.java:29)
      at hudson.remoting.Channel.call(Channel.java:240)
      at hudson.FilePath.act(FilePath.java:227)
      ... 10 more
      Caused by: java.io.NotSerializableException: hudson.scm.SubversionChangeLogBuilder
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1075)
      at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1369)
      at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1341)
      at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1284)
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1073)
      at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1369)
      at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1341)
      at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1284)
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1073)
      at java.io.ObjectOutputStream.writeObject(ObjectOutputStream.java:291)
      at hudson.remoting.UserRequest.serialize(UserRequest.java:88)
      ... 13 more

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          Fixed in 1.100.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            ramazanyich2 ramazanyich2
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: