Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4474

"403 Forbidden" when retrieving issues

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Won't Fix
    • Component/s: javanet-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      It seems that the disabling of the XML cgi introduced a major problem with this
      plugin.

      This is what I am seeing in my log:

      2009-sep-16 09:52:08 hudson.plugins.javanet.ReportGenerator run
      ALLVARLIG: Failed to generate java.net stat report for hudson
      org.kohsuke.jnt.ProcessingException: fetching the details of the issue
      0,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,
      30,31,32,33,34,35,36,37,38,39,40,41,42,43,44,45,46,47,48,49,50,51,52,53,54,55,56
      ,57,58,59,60,61,62,63,64,65,66,67,68,69,70,71,72,73,74,75,76,77,78,79,80,81,82,8
      3,84,85,86,87,88,89,90,91,92,93,94,95,96,97,98,99 Error on HTTP request: 403
      Forbidden [https://hudson.dev.java.net/issues/xml.cgi?
      include_empty_issues=false&include_attachments=false&id=0,1,2,3,4,5,6,7,8,9,10,1
      1,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,32,33,34,35,36,37,
      38,39,40,41,42,43,44,45,46,47,48,49,50,51,52,53,54,55,56,57,58,59,60,61,62,63,64
      ,65,66,67,68,69,70,71,72,73,74,75,76,77,78,79,80,81,82,83,84,85,86,87,88,89,90,9
      1,92,93,94,95,96,97,98,99]
      at org.kohsuke.jnt.Scraper.run(Scraper.java:31)
      at org.kohsuke.jnt.JNIssue.bulkFetch(JNIssue.java:450)
      at org.kohsuke.jnt.JNIssueTracker.get(JNIssueTracker.java:74)
      at org.kohsuke.jnt.JNIssueTracker.getAll(JNIssueTracker.java:93)
      at org.jvnet.its.Generator.generate(Generator.java:48)
      at org.jvnet.its.Generator.generate(Generator.java:38)
      at hudson.plugins.javanet.ReportGenerator.run(ReportGenerator.java:47)
      at
      java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:8
      86)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: com.meterware.httpunit.HttpException: Error on HTTP request: 403
      Forbidden [https://hudson.dev.java.net/issues/xml.cgi?
      include_empty_issues=false&include_attachments=false&id=0,1,2,3,4,5,6,7,8,9,10,1
      1,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,32,33,34,35,36,37,
      38,39,40,41,42,43,44,45,46,47,48,49,50,51,52,53,54,55,56,57,58,59,60,61,62,63,64
      ,65,66,67,68,69,70,71,72,73,74,75,76,77,78,79,80,81,82,83,84,85,86,87,88,89,90,9
      1,92,93,94,95,96,97,98,99]
      at com.meterware.httpunit.WebClient.validateHeaders(WebClient.java:569)
      at com.meterware.httpunit.WebClient.updateClient(WebClient.java:445)
      at com.meterware.httpunit.WebWindow.updateWindow(WebWindow.java:136)
      at
      com.meterware.httpunit.WebWindow.getSubframeResponse(WebWindow.java:127)
      at com.meterware.httpunit.WebWindow.getResponse(WebWindow.java:118)
      at com.meterware.httpunit.WebWindow.getResponse(WebWindow.java:99)
      at com.meterware.httpunit.WebClient.getResponse(WebClient.java:86)
      at org.kohsuke.jnt.JNObject.goTo(JNObject.java:33)
      at org.kohsuke.jnt.JNIssue$1.scrape(JNIssue.java:452)
      at org.kohsuke.jnt.JNIssue$1.scrape(JNIssue.java:450)
      at org.kohsuke.jnt.Scraper.run(Scraper.java:29)
      ... 12 more

        Attachments

          Activity

          evernat evernat added a comment -

          I suppose that the dev.java.net stat plugin can be removed.

          redsolo redsolo added a comment -

          Not interested in these changes anymore. Is the plugin used at all?


            People

            Assignee:
            kohsuke Kohsuke Kawaguchi
            Reporter:
            redsolo redsolo
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: