Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-45087

Manual trigger step fails with new version of Build Pipelilne Version

    XMLWordPrintable

Details

    Description

      I believe this is a re-occurrence of JENKINS-28146. I was going to reopen the ticket, however the issue is happening with a newer version.

      ISSUE: Jenkins returns "Could not trigger build! error: Server Error status: error" when triggering manual steps from the delivery pipeline.

      If I downgrade the Build Pipeline from 1.5.7 to 1.5.6, it works.

      Attachments

        Issue Links

          Activity

            tommysdk Tommy Tynjä added a comment -

            jlevis, sfblackl, gmc_devel, alex_baptista: Does JENKINS-23532 solve this issue for you (released in Delivery Pipeline plugin version 1.0.5)?

             

            tommysdk Tommy Tynjä added a comment - jlevis , sfblackl , gmc_devel , alex_baptista : Does JENKINS-23532 solve this issue for you (released in Delivery Pipeline plugin version 1.0.5)?  
            jlevis Joe Levis added a comment - - edited

            The issue is resolved for me.

            I'm running Delivery Pipeline Plugin 1.0.6. I don't think I ever installed 1.0.5 - went straight to 1.0.6 - so I can't say for sure that it was 1.0.5 that resolved it.

            However, looking at the description, I believe it was the Build Pipeline Plugin that was causing the issue. I upgraded from 1.5.6 --> 1.5.7.1 and the issue is resolved.

            jlevis Joe Levis added a comment - - edited The issue is resolved for me. I'm running Delivery Pipeline Plugin 1.0.6. I don't think I ever installed 1.0.5 - went straight to 1.0.6 - so I can't say for sure that it was 1.0.5 that resolved it. However, looking at the description, I believe it was the Build Pipeline Plugin that was causing the issue. I upgraded from 1.5.6 --> 1.5.7.1 and the issue is resolved.

            Hi!

            The issue has been resolved by fixing JENKINS-23532;
            Ie., update to Delivery Pipeline Plugin 1.0.5 and (also) Build Pipeline Plugin 1.5.7.1

            Thx, Markus

            gmc_devel GMC Software Development B&R Corporate added a comment - Hi! The issue has been resolved by fixing JENKINS-23532 ; Ie., update to Delivery Pipeline Plugin 1.0.5 and (also) Build Pipeline Plugin 1.5.7.1 Thx, Markus
            tommysdk Tommy Tynjä added a comment -

            jlevis, gmc_devel; Thank you for response. I will then close this issue as it is deemed JENKINS-23532 fixed the issue.

            tommysdk Tommy Tynjä added a comment - jlevis , gmc_devel ; Thank you for response. I will then close this issue as it is deemed JENKINS-23532 fixed the issue.

            Sorry for delay - I can confirm after upgrading to latest versions of plug-ins it all worked (we had also gone back to 1.0.3 which had worked).  Thanks for fixing.

            sfblackl Stewart Blacklock added a comment - Sorry for delay - I can confirm after upgrading to latest versions of plug-ins it all worked (we had also gone back to 1.0.3 which had worked).  Thanks for fixing.

            People

              Unassigned Unassigned
              jlevis Joe Levis
              Votes:
              9 Vote for this issue
              Watchers:
              13 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: