Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4529

Problem with Text-finder and Warnings plugin order execution

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: text-finder-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Hi,

      I have a project which run a shell script. During compilation, errors can occur,
      but the script doesn't stop until its end and then the compilation always
      succeed. Thus, I use the text-finder plugin to scan the console output and when
      it find the pattern corresponding to an error, it declares the build as a failure.

      The problem is that I use also the Warnings plugins, and this plugin is not
      suppose to launch if the build fails (permitting not to shows number of warnings
      in the warnings trend for failed builds, which could be completely wrong)

      Since the text-finder plugin runs after the warnings plugin, it could detect a
      build failure after the warnings are scanned and integrated to the trend.
      Warnings trend would then be wrong.

      I'm actually facing this case.

      Could it possible to make the text-finder plugin run before the warnings plugin?

        Attachments

          Activity

          basil Basil Crow added a comment -

          Recent versions of Jenkins allow one to drag and drop publisher to run in any order.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            metavalon metavalon
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: