Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-45721

Build parameter: No versions could be resolved for groupid.artifactid

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Hi,

      I would like to use the repository-connector-plugin as build parameter to retrieve all the possible version that are available for deployment.

      When I try to configure the parameter, I get the following message:

      "No versions could be resolved for groupid.artifactid"

      My configuration is attached.

       

      For information, when I use the same plugin using the "build step" instead of the "build parameter" it is working well ... (screen of the configuration attached). It's means that my "NEXUS" repository is accessible from jenkins and well configured.

       

      Can someone help?

        Attachments

        1. result.png
          result.png
          6 kB
        2. config.png
          config.png
          22 kB
        3. build_parameter.png
          build_parameter.png
          23 kB

          Activity

          Hide
          jgangemi Jae Gangemi added a comment -

          hello - are you still experiencing this issue?

          Show
          jgangemi Jae Gangemi added a comment - hello - are you still experiencing this issue?
          Hide
          beam_22 Mike Hunt added a comment -

          I am also having the same issue. Any one get around this bug?

          Show
          beam_22 Mike Hunt added a comment - I am also having the same issue. Any one get around this bug?
          Hide
          jgangemi Jae Gangemi added a comment -

          2.0.0 is due out in the next few days, please try that and see if it resolves your issues.

          please be sure to check the plugin readme before upgrading so you are aware of incompatible changes. the plugin no longer supports automatically setting the name of the version property, you must define that now yourself.

          Show
          jgangemi Jae Gangemi added a comment - 2.0.0 is due out in the next few days, please try that and see if it resolves your issues. please be sure to check the plugin readme before upgrading so you are aware of incompatible changes. the plugin no longer supports automatically setting the name of the version property, you must define that now yourself.

            People

            Assignee:
            jgangemi Jae Gangemi
            Reporter:
            kevinlf Kévin LE FOL
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: