Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-45844

Cannot bind folder credentials to pipeline shared library using Modern SCM option

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Minor
    • Resolution: Fixed
    • None
    • Windows Server 2012 R2 64 Bit
      Java SE 1.8.0_144
      Jenkins 2.60.2 (running as Windows service)
      Pipeline: Shared Groovy Libraries 2.8
      Credentials Plugin 2.1.14

    Description

      When adding a Jenkins shared library in a folder, the Modern SCM (using Git) option does not show credentials that are defined in that folder (the list is instead empty).

      With the Legacy SCM option, I can use credentials from the folder and everything works as expected.

      Attachments

        Issue Links

          Activity

            markewaite Mark Waite added a comment -

            Thanks for the clarification. I think I've made a mistake in earlier comments. I believe all of my pipeline library repositories are public, so my testing (to date) of this bug report has not been testing authentication. I'll have to double check when I spend more time on this.

            markewaite Mark Waite added a comment - Thanks for the clarification. I think I've made a mistake in earlier comments. I believe all of my pipeline library repositories are public, so my testing (to date) of this bug report has not been testing authentication. I'll have to double check when I spend more time on this.
            jacobtruman Jacob Truman added a comment -

            I see that this was resolved, but I do not see what the resolution was? I have the git plugin 3.5.1 installed and am having the same issue:

            GLOBAL credentials DO work on Modern and Legacy SCM

            FOLDER credentials DO NOT work on Modern SCM

            FOLDER credentials DO work on Legacy SCM

            jacobtruman Jacob Truman added a comment - I see that this was resolved, but I do not see what the resolution was? I have the git plugin 3.5.1 installed and am having the same issue: GLOBAL credentials DO work on Modern and Legacy SCM FOLDER credentials DO NOT work on Modern SCM FOLDER credentials DO work on Legacy SCM
            markewaite Mark Waite added a comment - - edited

            I presume it was resolved as a duplicate of JENKINS-44271, which was included in git plugin 3.5.1.  

            This bug is not mentioned in the git plugin changelog, so it may be that this is a different bug than JENKINS-44271.

            Since you're seeing that it does not work for you, please reopen the issue, and double check that the bug description accurately reflects the steps you take to see the bug.

            markewaite Mark Waite added a comment - - edited I presume it was resolved as a duplicate of JENKINS-44271 , which was included in git plugin 3.5.1.   This bug is not mentioned in the git plugin changelog , so it may be that this is a different bug than JENKINS-44271 . Since you're seeing that it does not work for you, please reopen the issue, and double check that the bug description accurately reflects the steps you take to see the bug.
            jacobtruman Jacob Truman added a comment -

            It looks like this (and my) issue is very similar to JENKINS-43802

            jacobtruman Jacob Truman added a comment - It looks like this (and my) issue is very similar to JENKINS-43802

            Credentials now show in the configuration, but are not used when checking out the library. Anyway, this is tracked in JENKINS-43802, so there is no need to reopen this issue.

            procom_bl Thomas Bächler added a comment - Credentials now show in the configuration, but are not used when checking out the library. Anyway, this is tracked in JENKINS-43802 , so there is no need to reopen this issue.

            People

              Unassigned Unassigned
              procom_bl Thomas Bächler
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: