XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: other
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      I have this on several Projects since last night. The .100-Build has the same
      problems:

      java.io.IOException: Broken pipe
      at java.io.FileOutputStream.writeBytes(Native Method)
      at java.io.FileOutputStream.write(FileOutputStream.java:260)
      at java.io.BufferedOutputStream.flushBuffer(BufferedOutputStream.java:65)
      at java.io.BufferedOutputStream.flush(BufferedOutputStream.java:123)
      at
      java.io.ObjectOutputStream$BlockDataOutputStream.flush(ObjectOutputStream.java:1631)
      at java.io.ObjectOutputStream.flush(ObjectOutputStream.java:666)
      at java.io.ObjectOutputStream.close(ObjectOutputStream.java:687)
      at hudson.remoting.Channel.close(Channel.java:355)
      at hudson.maven.ProcessCache$MavenProcess.discard(ProcessCache.java:91)
      at hudson.maven.ProcessCache$MavenProcess.recycle(ProcessCache.java:78)
      at hudson.maven.MavenBuild$RunnerImpl.doRun(MavenBuild.java:268)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:119)
      at hudson.model.Run.run(Run.java:544)
      at hudson.maven.MavenBuild.run(MavenBuild.java:125)
      at hudson.model.Executor.run(Executor.java:61)

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          Any chance this is related to issue #444?

          troggan troggan added a comment -

          No, Version 102 didn't fix this problem

          troggan troggan added a comment -

          The error still occours in .103

          kohsuke Kohsuke Kawaguchi added a comment -

          Looks like 1.103 didn't fix issue #444 anyway.

          kohsuke Kohsuke Kawaguchi added a comment -

          Fixed in 1.104, I think (but hard to say since I can't reproduce this.)

          troggan troggan added a comment -

          Yes, this seems to fix the bug.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            troggan troggan
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: