Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-471

Unnecessary stack trace dump

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      When the POM referenced by another POM doesn't exist, Hudson produces an awfully
      long error message with stack trace like the following. Since this is an user
      error, just the stack trace is unnecessary:

      A
      thread-scope/src/main/java/org/jvnet/jax_ws_commons/thread_scope/ThreadScope.java
      A
      thread-scope/src/main/java/org/jvnet/jax_ws_commons/thread_scope/ThreadScopeInstanceResolver.java
      A
      thread-scope/src/main/java/org/jvnet/jax_ws_commons/thread_scope/ThreadScopeFeature.java
      A thread-scope/pom.xml
      At revision 208
      Parsing POMs
      ERROR: Failed to parse POMs
      hudson.util.IOException2: remote file operation failed
      at hudson.FilePath.act(FilePath.java:234)
      at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:192)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:121)
      at hudson.model.Run.run(Run.java:560)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:131)
      at hudson.model.Executor.run(Executor.java:61)
      Caused by: hudson.util.IOException2: Could not find the model file
      '/files/hudson/workspace/jaxws-commons/trunk/pom/../json/pom.xml'.
      at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:301)
      at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:253)
      at hudson.FilePath$FileCallableWrapper.call(FilePath.java:904)
      at hudson.remoting.UserRequest.perform(UserRequest.java:57)
      at hudson.remoting.UserRequest.perform(UserRequest.java:22)
      at hudson.remoting.Request$2.run(Request.java:178)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
      at java.lang.Thread.run(Thread.java:595)
      Caused by: org.apache.maven.project.ProjectBuildingException: Could not find the
      model file '/files/hudson/workspace/jaxws-commons/trunk/pom/../json/pom.xml'.
      at
      org.apache.maven.project.DefaultMavenProjectBuilder.readModel(DefaultMavenProjectBuilder.java:1274)
      at
      org.apache.maven.project.DefaultMavenProjectBuilder.buildFromSourceFileInternal(DefaultMavenProjectBuilder.java:414)
      at
      org.apache.maven.project.DefaultMavenProjectBuilder.build(DefaultMavenProjectBuilder.java:192)
      at hudson.maven.MavenEmbedder.readProject(MavenEmbedder.java:269)
      at hudson.maven.MavenUtil.resolveModules(MavenUtil.java:73)
      at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:287)
      ... 8 more
      Caused by: java.io.FileNotFoundException:
      /files/hudson/workspace/jaxws-commons/trunk/pom/../json/pom.xml (No such file or
      directory)
      at java.io.FileInputStream.open(Native Method)
      at java.io.FileInputStream.<init>(FileInputStream.java:106)
      at java.io.FileReader.<init>(FileReader.java:55)
      at
      org.apache.maven.project.DefaultMavenProjectBuilder.readModel(DefaultMavenProjectBuilder.java:1269)
      ... 13 more
      finished: FAILURE

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          Fixed in 1.102.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            kohsuke Kohsuke Kawaguchi
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: