Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-47204

Creating a pipeline from Git repository

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Minor
    • Resolution: Cannot Reproduce
    • blueocean-plugin
    • Safari, Jenkins LTS
      1.2.4
      · Core 2.73.1
      · e2b50bd
      · (no branch)
      · 19th September 2017 06:42 AM
    • Blue Ocean 1.4 - beta 1, Blue Ocean 1.4 - beta 2

    Description

      I tried the Blue Ocean UI for creating a new pipeline and selected Git as my source. I filled in my credentials, similar to git@git.server.local:reponame and selected the correct credentials. While the pipeline job was correctly created, it ended up with the name git@git instead of reponame as I had expected it to.

      Attachments

        Activity

          jamesdumay James Dumay added a comment -

          Hi krachynski,

          Thanks for the report. Could you give reproduction steps for this problem? It was unclear to me to what is exactly happening here.

          Thanks,
          James

          jamesdumay James Dumay added a comment - Hi krachynski , Thanks for the report. Could you give reproduction steps for this problem? It was unclear to me to what is exactly happening here. Thanks, James
          jamesdumay James Dumay added a comment -

          Please re-open again when there are reproduction steps.

          jamesdumay James Dumay added a comment - Please re-open again when there are reproduction steps.
          krachynski Ken Rachynski added a comment -

          Huh, I missed seeing the request, but did see your close emails.

          Steps to reproduce:

          1. Click on New Pipeline
          2. Click on Git for "Where do you store your code"
          3. Fill in the Repository URL. i.e. git@git.server.local:users/krachynski/jenkinspipeline
          4. Click "Create Pipeline"

          Well dang. The UI has changed since I reported this. It's now asking me to use a specific public SSH key instead of the one my Jenkins Server has already registered with our Git server. According to the documetation, I should have a credentials selector which I don't.

          So I guess I can't reproduce this either. Can't successfully create a pipeline now either, but that's a separate issue.

          krachynski Ken Rachynski added a comment - Huh, I missed seeing the request, but did see your close emails. Steps to reproduce: Click on New Pipeline Click on Git for "Where do you store your code" Fill in the Repository URL. i.e. git@git.server.local:users/krachynski/jenkinspipeline Click "Create Pipeline" Well dang. The UI has changed since I reported this. It's now asking me to use a specific public SSH key instead of the one my Jenkins Server has already registered with our Git server. According to the documetation, I should have a credentials selector which I don't. So I guess I can't reproduce this either. Can't successfully create a pipeline now either, but that's a separate issue.
          kshultz Karl Shultz added a comment -

          Testing Notes:

          • Adding a line or two to GitCreationTest.java to verify that the Pipeline ended up with the correct name seems a simple way to look for this regression.
          kshultz Karl Shultz added a comment - Testing Notes: Adding a line or two to GitCreationTest.java to verify that the Pipeline ended up with the correct name seems a simple way to look for this regression.

          People

            jamesdumay James Dumay
            krachynski Ken Rachynski
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: