Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-47743

“SHA-1 mismatch” after installing SSL certificate

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Component/s: other
    • Labels:
      None
    • Environment:
      Jenkins ver. 2.73.2; OS: Centos6.8
    • Similar Issues:

      Description

      Because we have our own CA certificate authority in my company, using https for Jenkins update center wasn't possible (empty plugin list). I used the following guide (link) to add our certificates to JVM which resolved my "empty list issue"; but when trying to actually install one of the plugins I am receiving the following error:

      {{java.io.IOException: Downloaded file /var/lib/jenkins/plugins/ccm.jpi.tmp does not match expected SHA-1, expected 'Begz4m+YT3VCEImnIOEg3/Dzi9s=', actual 'pWKXa4iUnlHx2iEAfRJYJLf3DVE=' }}

        Attachments

          Activity

          danielbeck Daniel Beck added a comment -

          Likely caused by broken proxy configuration or similar; this report doesn't show there's a bug in Jenkins.

          frazz Fikri Razzouki added a comment - - edited

          Leonardo Akor did you solve this?

          alospider Leonardo Akor added a comment -

          Actually no. 

          We did a workaround by changing the update  site from https to http.

           


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            alospider Leonardo Akor
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: